Support » Plugin: Selection Sharer by Hans van Gent » Doesn't work on IE11

  • Hey, I saw your other comments that you were fixing things in IE11. For what I see, it doesn’t work at all on IE11. On Microsoft Edge, it works but the icons don’t show up (instead, I see a black speech bubble).

    So.. I don’t know if it’s fixed as reported on the IE8 post here. Would love to know though if you know where that stands.

    Thanks!! Great plugin, very clean, and works great on Chrome/FF.

    https://wordpress.org/plugins/selection-sharer/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author jcvangent

    (@jcvangent)

    Hey Tamar,

    I just pushed a new version with an IE fix as reported here in the forums. Not sure if this solves your problem as well though since I don’t have IE for testing available here..

    Could you check and see if it solves your problem?

    Thanks!
    Hans

    Thread Starter tamar

    (@tamar)

    Unfortunately it doesn’t 🙁

    Plugin Author jcvangent

    (@jcvangent)

    Mmm problem is, that I don’t have IE11 here myself. Are you familiar with developer tools in IE? By pressing F12 you should be able to see debugging information (as outlined here for example: https://www.davrous.com/2014/08/22/enhance-your-javascript-debugging-life-using-ie11-chrome-opera-firefox-source-map-support/) could you maybe see if you find an error displayed there?

    Thanks!
    Hans

    Thread Starter tamar

    (@tamar)

    I have no idea what to look for (but I can turn on debugging mode). You don’t know anyone with a PC you can check on?

    Plugin Author jcvangent

    (@jcvangent)

    Do you’ve got it currently running on a website? Otherwise I can try to see if I can install a virtualmachine on my laptop to do some debugging 🙂

    Hans

    Thread Starter tamar

    (@tamar)

    sure try it on [edited].com. 😉

    Plugin Author jcvangent

    (@jcvangent)

    Sorry to bother you again 🙂 but I might have found a solution, could you maybe test it by downloading the following css file:

    https://we.tl/yv8E4n0gz6

    And replacing the current file located on your webserver here:

    wp-content/plugins/selection-sharer/css/selection-sharer.css

    I re-encoded the SVG files in the css, let me know if that new CSS works and I will release another update with it for everyone 🙂

    Thread Starter tamar

    (@tamar)

    Nope. 🙁

    Plugin Author jcvangent

    (@jcvangent)

    You don’t have FTP access to your server? Mmm okay let me try to find another solution to test it 🙂

    Thread Starter tamar

    (@tamar)

    No, I do. It’s there. It didn’t solve the problem.

    Plugin Author jcvangent

    (@jcvangent)

    Yeah just uploaded to a newly created test WordPress install too and they don’t show up there in my virtual windows environment too..

    Mmm wondering what it than could be.. I used a different encoding type for the SVG reference which should work from what I can find online. Back to the drawing board it is then! :-/

    Plugin Author jcvangent

    (@jcvangent)

    Mmm you removed the website 🙂

    Do you’ve got this in between the <head></head> on your template:

    <meta http-equiv=”X-UA-Compatible” content=”IE=edge”>

    Or maybe something like:

    <meta http-equiv=”X-UA-Compatible” content=”IE=8″>

    In case the latter or none, could you add the first one?

    Thread Starter tamar

    (@tamar)

    I did 😉 You need it? I will edit it back again.

    [editedagain].com

    I added that meta tag but it is still not working.

    Plugin Author jcvangent

    (@jcvangent)

    aarfff 😉 at one moment there will be a solution be assured about that!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Doesn't work on IE11’ is closed to new replies.