Support » Plugin: Bulk Delete » Doesn’t work on CPT

  • Tried this plugin to bulk-delete almost a thousand posts of a custom post type because apparently WP doesnโ€™t include that in it’s ‘bulk actions’ (WTF? Why would anyone NOT want the ability to bulk-manage CPTs?)

    SO I installed and activated this plugin, carefully went thru the settings to choose my (2) custom post types for which I want all posts deleted, clicked “OK” to the warning message asking if I really wanted to do this, then the screen refreshed but NO POSTS WERE DELETED! I tried three times.

    Plain and simple, this plugin does not seem to work. ๐Ÿ™

    UPDATE: EVEN WORSE – I cannot delete this plugin!! I’ve deactivated it and when I try to delete it via the WP Admin>Plugins page it does not delete! I am deleting it via FTP, but really, what crappy coding!

    • This topic was modified 2 years, 1 month ago by  TrishaM.
Viewing 1 replies (of 1 total)
  • Plugin Author Sudar Muthu

    (@sudar)

    Okay, looks like some other plugin is interfering with the deletion process.

    Is this custom post type created by a plugin? Some plugins (especially event related ones) override the SQL to retrieve all posts using filters which might break the deletion process. Can you give me the name of the plugin that is creating this custom post type? I can have a look at it and see if I can add an exception for it. Previously I have worked with other plugin authors and have helped them fix this issue in their plugin (and follow proper WordPress coding standard).

    Regarding you not able to delete the plugin, just make sure the permissions on your wp-content directory is setup correctly. WordPress won’t be able to delete the plugin (or theme) if the directory permissions are not correct. This has nothing to do with my plugin or how crappy (or awesome) the code is ๐Ÿ˜‰

Viewing 1 replies (of 1 total)
  • The topic ‘Doesn’t work on CPT’ is closed to new replies.