Support » Plugin: Conditional Menus » Doesn’t work for subpages

  • Resolved Cezariusz Marek

    (@cezariuszmarek)


    Hello,
    I’m using the 1.1.5 version and it doesn’t work for 1st level subpages.

    It works only if I do this:

    • Make the page top-level
    • Select it in a condition -> it works
    • Change it to a subpage -> it works, but in the condition it appears as not selected

    If I select it again in the condition (and save), it won’t work.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 32 total)
  • Plugin Author themifyme

    (@themifyme)

    Hi,

    After you change the page hierarchy, check the conditions again in Condition Menus and then re-save it.

    Thread Starter Cezariusz Marek

    (@cezariuszmarek)

    But as I said it doesn’t work for subpages.

    Plugin Author themifyme

    (@themifyme)

    Could you post screenshots of your menu setup and conditions? Without seeing the menu conditions, it is hard to judge.

    Thread Starter Cezariusz Marek

    (@cezariuszmarek)

    The condition works on the Polska wersja page, but it doesn’t work on the Możliwości subpage.

    Plugin Author themifyme

    (@themifyme)

    Hi,

    Thanks for the detail screenshots. The conditions seem to be fine. Could you check if you are using the latest Conditional Menus? The latest version is 1.1.5 at the moment: https://wordpress.org/plugins/conditional-menus/

    We’ve tested at our end and it seems to be working sub-pages: https://themify.me/demo/themes/conditional-menus/page-a/page-sub-1/ (you go back to home to test all other page conditions).

    Thread Starter Cezariusz Marek

    (@cezariuszmarek)

    Yes, I have the latest version:

    Plugins

    Same problem here, from the latest version newly created subpages dont work.

    Plugin Author themifyme

    (@themifyme)

    @dave_cl

    Could you post a screenshot of the following:
    – Menu setup
    – Conditional menu setup (the lightbox where you have the sub-pages checked)

    Please provide the sub page URL where we can see it.

    • This reply was modified 1 year, 2 months ago by themifyme.
    Plugin Author themifyme

    (@themifyme)

    @cezariuszmarek

    It looks like your site is bilingual. So you have English and Polish version of the pages. Are you sure the page conditions are checked correctly?

    Thread Starter Cezariusz Marek

    (@cezariuszmarek)

    It looks like your site is bilingual.

    It is, that’s why I need two separate top menus. I have posted the screenshots of my conditions – what else can I check? And note that it works for the first level page, and it works if I change the subpage to the top level page, check the condition, and than change it back to a subpage. So it’s definitely a problem with checking the conditions.

    Plugin Author themifyme

    (@themifyme)

    I think we’ve found the problem. Does your menu have different view type conditions? (ie. do you have the sub pages checked and another view type checked?)

    We’ve confirmed that bug and will fix it in the next update. Meanwhile, please select the sub-page conditions. If you need the menu on other view types, please add another conditional menu.

    Thread Starter Cezariusz Marek

    (@cezariuszmarek)

    Does your menu have different view type conditions? (ie. do you have the sub pages checked and another view type checked?)

    What do you mean? I have posted you screenshots of all my settings. I don’t know what are the view type conditions.

    please select the sub-page conditions.

    Could you please show me a sample?

    @cezariuszmarek Hey, do you use any bilingual plugin like WPML or something like that?

    Thread Starter Cezariusz Marek

    (@cezariuszmarek)

    do you use any bilingual plugin like WPML or something like that?

    No, I don’t. Here are my Plugins.

    @cezariuszmarek Have you try to disable plugins one by one to make sure if the problem is a plugin conflict or not?

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Doesn’t work for subpages’ is closed to new replies.