Support » Plugin: Forum Restrict » Doesn't work for current versions

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author rexgoode

    (@rexgoode)

    Try the latest.

    Hello rexgode,

    I’m using WordPress v3.5.1 together with bbPress v2.3 and Forum Restrict v1.4 (aka v1.5 as it says in the readme, downloaded today, no other plugins activated).

    After installing Forum Restrict I get a “Forum Restrict is intended to work exclusively with sites with the bbpress plugin activited. You must install and activate bbpress plugin for this plugin to work.” on every site at the admins’ panel though bbPress is already activated and running.

    I even can change the settings like “Restrict access to this forum using Forum Restrict plugin.” etc. under the “Forums” menue, but when it comes to more specific settings under “Users > Forum Restrictions”, while selecting a forum under “Forum Restrictions Administration” it says “ReferenceError: WriteForum is not defined”.

    Did I do something wrong? Thanks alot in advance for your help.

    Regards,

    Tom

    I have exactly the same problem: ReferenceError: WriteForum is not defined. I have the latest version.

    It’s because rexgoode in newest version forgot to include two additional files required by index.php which are:

    1. forum_restrict.js
    2. setmessages.php

    I’ve downloaded these from http://plugins.svn.wordpress.org/forum-restrict/tags/1.3/ (for older version) and put it in wp-content/plugins/forum-restrict.

    Now I am able to use this plugin, but it still doesn’t give me proper functionality, because even if I restrict forum for certain users only (this doesn’t work well also), I can always go directly to this forum typing http://<my_site>/forums/forum/<forum_name&gt; in address bar.

    I’m not sure if this is caused because of incompatibilty of these two files mentioned above which I got from different version of the plugin?

    rexgood, are you alive? 🙂

    Thank you lisu, now it works!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Doesn't work for current versions’ is closed to new replies.