Support » Plugin: WP OAuth Server » Doesn’t Work At All

  • lsankey

    (@lsankey)


    This plugin is completely non-functional. Spent hours trying everything and looking for solutions. It just doesn’t work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Sorry you feel this way about the plugin. There has been over 10k people that have installed this plugin with success!

    Have you reached out through our support channel for assistance?

    lsankey

    (@lsankey)

    I’m sure it used to work, but it’s not working now. I searched for answers and I’m not the only one saying it doesn’t. It loads with several warning errors. I followed several threads of people with the same problems I was having and nothing worked. Seems it’s not working for a few people.

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Please share these issues that you are having. I would love the chance to help you with any issues and ultimately your project.

    We have put a ton of work into this project and stand by it. We have support through these forums as well as direct support open for all.

    dingobytes

    (@dingobytes)

    As a developer and contributor to open source projects, this review is aggravating. The review should be constructive and at the very least give specifics. A review stating the “plugin is completely non-functional” without any context and or errors is useless.

    We have used this plugin off and on for some time and the plugin has always worked fine. Notices some warnings and errors in logs, but nothing that directly affected how we used the plugin and all of those warnings have been fixed with later releases. In fact any issues we encountered were always caused by implementing/using the plugin incorrectly.

    If we had to give criticism, our only constructive criticism would be that some of the documentation appears to be outdated (but only in how the plugin works with third party tools). That criticism is only indirectly related to the plugin.

    With that said, we would hope anyone staggering to this review knows that this plugin deserves a five star rating. Contrary to what @Isankey has stated this plugin works and it works well.

    Thanks for your work and a great plugin @justingreerbbi!

    lsankey

    (@lsankey)

    Using this plugin was aggravating and I admit that after struggling with it for hours over several days I did not feel like going through everything I did in a review. So the review is out of frustration. I will say this, all I ever got out of the plugin while trying to authenticate was messages like, “Could not complete OAuth 2.0 login. Check Postman Console for more details.”

    I have authenticated with Oauth2 in Postman many times before. I am not unfamiliar with the process. Now I am spending more time looking for the stackoverflow solutions I tried over days to resolve this problem to answer this comment. I can authenticate with Basic Authentication without a problem. But I did reinstall it and got a console message I did not get before.

    <head/>
    <br/>
    <b>Fatal error</b>: Uncaught Error: Call to a member function get_client() on null in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/OAuth2-master/inc/authentication/namespace.php:120
    Stack trace:
    #0 /opt/bitnami/apps/wordpress/htdocs/wp-includes/class-wp-hook.php(286): WP\OAuth2\Authentication\attempt_authentication(false)
    #1 /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php(203): WP_Hook->apply_filters(false, Array)
    #2 /opt/bitnami/apps/wordpress/htdocs/wp-includes/user.php(2603): apply_filters(‘determine_curre…’, false)
    #3 /opt/bitnami/apps/wordpress/htdocs/wp-includes/pluggable.php(69): _wp_get_current_user()
    #4 /opt/bitnami/apps/wordpress/htdocs/wp-includes/capabilities.php(613): wp_get_current_user()
    #5 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/all-in-one-seo-pack/admin/display/menu.php(14): current_user_can(‘manage_options’)
    #6 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/all-in-one-seo-pack/admin/display/menu.php(38): AIOSEOPAdminMenus->__construct()
    #7 /opt/bitnami/apps/wordpress/ht in
    <b>/opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/OAuth2-master/inc/authentication/namespace.php</b> on line
    <b>120</b>
    <br/>

    lsankey

    (@lsankey)

    Also, I tried the plugin both on a live site and on a VM locally.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Doesn’t Work At All’ is closed to new replies.