WordPress.org

Support

Support » Plugins and Hacks » doesn't work at all …

doesn't work at all …

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author tambourdeville

    @tambourdeville

    Hi,
    You normally don’t have to copy the file, the plugin do it for you.
    Something is wrong about the site, or the wordpress adress: it’s just that the plugin can’t find the file to copy, and I don’t get why.

    Do you have the same error messages in the dashboard ?
    Is there something special with your WP site adress ?
    What kind of permalinks are you using ?

    Anyway, you still can modify the file “flip-pong-V.php” in the plugin directory. If you delete the line 183, it will disable the copy.

    About the flipbook: right now you don’t have any picture in there, did you upload any one from the post-edit screen ?

    Hi tambour,
    thanks for your response.

    1. 3 pictures are assigned to the flip book.

    2. activated flip pong on another website without anything doing manually – the result is that the flipbook is not found and just the last post with featured image taken.
    Checked the theme folder and the single-flip_pong.php was NOT copied there automatically.

    3. Flip-pong-V.php has only 183 lines. which part should i delete then ?

    4. On the other website removed instead in flip-pong-V.php the whole //*********** File Copy ****************// part & copied again single-flip.pong.php manually. result looks now like here.

    Just out of curiosity: Is this line right in the copy part : $target = get_stylesheet_directory_uri(); ? uri ? not url?

    fyi … I am using the theme ‘Immense’ from Graphpaperpress and it is a child theme. Immense creates an own taxonomy for its galleries, but one can also use the gallery shortcode in a post directly.

    Hope all these informations help to find the conflict.

    btw … I am the one, who forwarded your plugin to Emmanuel, the guy behind turnjs. Hopefully soon flip-pong can integrate the 5th version of turnjs soon 🙂

    A bientôt

    another test : tried it on another domain with the original wp-theme twenty twelve
    it works fine … also when all other plugins of the two other websites are activated.
    So it is not a plugin conflict.

    The plugin works fine with one exemption:
    try to turn back the last page … the turn.js doesn’t work and drags the picture!

    tried then my theme ‘Immense’ – a fullscreen photo theme – and then the flipbook doesn’t work anymore, but is displayed like one of its galleries with their single-galleries.php.
    So the issue is theme-related .. also the mother theme does’t work with it and displays just the pics. Will contact the theme developer.

    ok … just updated the theme and now it works partly with the theme

    Problem is now only, that the loading circle is there permanently and flipping the last page is still not working.

    :Nooriji

    Are you sure you have the actual version downloaded? I just checked my files:
    1) Flip-pong-V.php has 188 lines.
    2) I do not find the line: $target = get_stylesheet_directory_uri();

    Regards

    Markus

    @ Markus:

    here is an extract of flip-ping_V.php
    * Author URI: http://www.tambourdeville.net
    * Version: 1.3.1
    **/

    class flippong{
    function check_version(){
    if (!is_admin()){
    $fileok = plugins_url().’/flip-pong-v/single-flip_pong.txt’;
    $filecheck = get_stylesheet_directory_uri();

    I just wondered why it is _uri and not _url …

    Plugin Author tambourdeville

    @tambourdeville

    Hi!
    -I didn’t use the function “get_stylesheet_directory_url();” because it doesn’t exist 😉
    And the _uri works fine for me and a lot of people, you’re the first one to have issues with that. I would like to figure out why…

    -Can you try to download again the plugin and replace the files ?
    ’cause Markus is right: the file flip-pong_V has 188 lines.
    The one I would advice to delete is the #183:
    add_action(‘init’, array(‘flippong’,’check_version’ ));

    -The loading circle doesn’t come from our plugin, I guess it’s from your theme or another plugin.. I can’t do anything about that.

    -You said “flipping the last page is still not working”.
    But on this flipbook: http://www.so.is/0_WP/?flip_pong=test-on-another-theme , you have only 3 pictures uploaded in the post. It’s normal that only 3 pictures appear in the flipbook…

    I hope it helps!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘doesn't work at all …’ is closed to new replies.