Support » Plugin: Auto Post WP to Photo Social Network » Doesn’t work anymore :-(

  • Resolved Steffen

    (@stevie77)


    The plugin worked very well during my summer holidays where I posted about 50 articles. But yesterday I posted another article and there was no picture on instagram. Is there a possibility to see in a log file what happened? Or what didn’t happen?
    I think most users have the same problem, the plugin stopped working (perhaps because of instagram changes). Please go troubleshooting and repair it.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor dufour_l

    (@dufour_l)

    Hello Stevie

    I proposed a tips/fix a few days ago, can you try it just in case ?

    Details below

    Laurent.

    ——————————-

    Hello Guys,
    I had the same issue since a few hours today.

    Now I have found a work around that I share with you.

    The root cause of the issue probably came from Instagram in the yway they check the login and password.

    But so far in the plugin code, there is a use of a sub library “mgp25/Instagram-API” and in the way it is used so far there where something like

    $i = new \InstagramAPI\Instagram($username, $password, $debug);

    try {
    $i->login();
    } catch (Exception $e) {
    $e->getMessage();
    exit();
    }

    And the problem come from the phase whith the try section where it tries to authenticate twice the user. This has worked so far, but today it does not work anymore.

    The first line $i = new \InstagramAPI\Instagram($username, $password, $debug); already login the plugin to instagram.

    So to make it works, now I had to put in comment the following lines (Around line 724 to 729 in wp2instagram.php )

    //try {
    // $i->login();
    //} catch (Exception $e) {
    // $e->getMessage();
    // exit();
    //}

    And now my post are shown again in instagram.

    So Roland (The author of the plugin), if you pass here I do not know if this is normal or not or if something needs to be adapted with a new version of the plugin.

    I just wanted to share this tips with all of you.

    Laurent Dufour

    Thread Starter Steffen

    (@stevie77)

    Nope, unfortunately this doesn’t work for me (like the user marinkom replied to your post). I commented out the section you told me. The WordPress frontend timed out while saving the changed file, but when I download or inspect the file wp2instagram.php via FTP from the server, the changes are online. Do I have to deactivate and reactivate the plugin to reload the code or something like that? A caching problem?
    I posted a new article with a main picture, but nothing to see on my instagram account…

    Thread Starter Steffen

    (@stevie77)

    Deactivated and reactivated the plugin and tried again without any positive result.

    Plugin Author Roland Alla

    (@rolandalla91)

    The plugin is now updated with the @dufour_l suggestions ,
    Also for everyone Who want to contribute the Plugin is in Github.
    https://github.com/rolandalla/wordpress-to-instagram

    Best Regards

    Hello Rolland.

    Still not working even with the new version. Its saving fine (not blank page) but not posting to Instagram.

    • This reply was modified 2 years, 10 months ago by Seila162.
    Thread Starter Steffen

    (@stevie77)

    Doesn’t work for me either (version 1.4.5). It says ‘Instagram Status : Already published’, but it wasn’t. I have WordPress 4.9.8 installed.
    I enabled the debug checkbox – where can I see the debug messages?

    • This reply was modified 2 years, 10 months ago by Steffen.

    O meu também parou de funcionar quando atualizei, voltei para a versão antiga e fiz as modificações que Laurent Dufour falou, mas mesmo assim ainda não posta no instagram.

    Plugin Contributor dufour_l

    (@dufour_l)

    Hello Guys

    Can you all try with the new version 1.4.6

    Regards

    Hi,

    The initial suggestion to comment out this….
    //try {
    // $i->login();
    //} catch (Exception $e) {
    // $e->getMessage();
    // exit();
    //}
    Actually did work for a couple of weeks, and then it stopped again the other day.

    I updated to Version 1.4.6 but this is also not working for me.

    The post status shows this…..
    Instagram Status : Never published

    Posted : Unknown

    Upload info : Something went wrong while uploading your photo: login_required

    Instagram response :

    Your Account : https://instagram.com/transfer.design

    Thanks,
    Marinko

    • This reply was modified 2 years, 10 months ago by marinkom.
    Plugin Contributor dufour_l

    (@dufour_l)

    Hi Marinkom

    The error that you have is related to Instagram security process, you faced an issue when login to instagram from two different IP adresses.
    Please try the tips from this website to solve it : https://instazood.com/how-to-fix-checkpoint-required-error-on-instagram/

    Hi dufour_l,

    I will give that a go, and see how I go.
    Thanks for your help.

    Regards,
    Marinko

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Doesn’t work anymore :-(’ is closed to new replies.