WordPress.org

Support

Support » Plugins and Hacks » Simple Lightbox » [Resolved] Doesn't work after update

[Resolved] Doesn't work after update

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Archetyped

    @archetyped

    I looks like you might have a caching plugin on your site. I would clear the cache and possibly deactivate it to test to make sure that cached data is not causing issues with loading.

    I have the same problem. I purged the cache and restarted nginx and php. still no go.

    using photon if that helps…

    Same – now broken…

    Maybe it is related to the js being moved to the footer ? Mine not working too …

    Tried deactivating cache plugin but still broken.

    I also think it might have something to do with being in footer and possibly timing out.

    I know the previous version would do the same thing thing if you clicked before the page fully loaded.

    Plugin Author Archetyped

    @archetyped

    If other users can provide a link to a page exhibiting the issue, I’d be glad to take a look. Until then, there’s no way to confirm that the same issue is causing SLB not to work.

    @l7world: At least in your case, the problem is that SLB’s libraries are not being loaded in the page at all. This may be related to the fact that jQuery (required by SLB) is not being loaded on the page either.

    It also appears that the cached/minified JavaScript is not being properly loaded on your site either. It’s returning a 404 (file not found).

    If you can fully disable the caching plugin so that I can take a look at the site without caching involved, that may help us get to the root of the issue.

    Cache plugin is off now.

    I found out that mine has a problem when “Better WordPress Minify” is activated, this minifies the javascript. No problem in previous version of beta, so I guess moving it to the footer brought out the problem.

    I cannot deactivate BWP of course as it services other plugins for more efficient js handling.

    So trying to figure it out …

    Maybe add an option to load in header or footer ? Thanks

    Plugin Author Archetyped

    @archetyped

    @l7world.com: Thanks, SLB is now loading on your site.

    However, it appears that some other JavaScript files have been commented out from your theme (e.g. Cufon, jQuery UI, etc.), yet the code they are supposed to load is still being referenced.

    This causes an error which stops execution of other JS code such as SLB.

    Fixing those issues in your theme should allow SLB to work properly.

    Also, note that loading other lightboxes (e.g. prettyPhoto) may conflict with SLB’s operation since they are both supposed display an image in a lightbox when clicked.

    Plugin Author Archetyped

    @archetyped

    @astrasuite: So when BWP is deactivated, SLB loads properly?

    Minification aside, it doesn’t appear that SLB’s non-JS content is being loaded. This indicates a caching issue. Clearing the site’s cache and temporarily deactivating the caching plugin should allow SLB’s content to load properly.

    If you let me know when the caching plugin is deactivated, I’d be glad to take a closer look.

    Yes, no problem at all when BWP is deactivated. Problem is probably something to do with minification, and others may be using some other plugin that minifies (?).

    I tested by deactivating all and reactivating one by one. Easy to do as I use “Plugin Organizer”.

    BWP was fine with previous beta versions for testing.

    BWP has an option to load js in header, but one must know the registered name, and I cannot find any name called by a wp_enqueue_script to try.

    However, some other js from other plugins have no problem being loaded in footer, but they do have registered names.

    Caching is no issue , perfect with W3 Total Cache, as long as BWP is deactivated. BWP also has a cache, and it has been cleared, and still same problem.

    Currently testing here :

    Living Voice OBX-RW With VOX Olympian in Munchen High End Show 2013

    BWP currently deactivated. W3 Total Cache activated, and no problem. You can go see it. HTML is compressed though, of course, for efficiency. You can go to another page, go back again, and see w3 cache working well, as well as simple lightbox.

    If I reactivate BWP, it won’t work again. like here where BWP is activated. I can do this selectively because of the fantastic Plugin Organizer.

    The New Voxativ Pi Loudspeakers

    So I compared both htmls of above, the one with BWP versus the one without.

    I don’t know if this helps, I’m no programmer :

    Without BWP, it loads this, for example, with something appended at the end :
    simple-lightbox/client/js/lib.view.js?ver=2.0RC2.1

    With BWP, it loads this, without anything appended (although one can append something as an option):

    simple-lightbox/client/js/lib.view.js

    Plugin Author Archetyped

    @archetyped

    @astrasuite: Thanks, SLB is now loading on both pages you provided.

    However, it appears that BWP rearranges the order of code execution on the page. The order of SLB’s code execution is quite specific, which is why you’re getting unexpected behavior when BWP is activated.

    Yes, I noticed that too, rearranging, and it still doesn’t work for me in the page with BWP :

    The New Voxativ Pi Loudspeakers

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] Doesn't work after update’ is closed to new replies.
Skip to toolbar