Support » Plugin: Velvet Blues Update URLs » Doesn't work after latest release; can't roll back

  • Resolved Michelle


    Hi – first thanks for the great plugin! I used it on a bunch of sites in a multisite installation a couple of weeks ago and it was working perfectly.

    However since I updated the plugin to 3.2, I’m getting a “Error: something may have gone wrong / Your URLs have not been updated” message whenever I try to use the plugin. The first time I run it, I see numbers in the ‘results’ area that correspond to the search query (27 Content items, etc) – but no urls are updated. When I re-run, all the ‘Results’ show as 0 count.

    I tried downloading 3.1 and rolling back to that, but apparently the ZIP file for that version actually contains version 3.2, not 3.1.

    I’m running WP 3.6.1 on WPEngine. I’ve cleared cache and done everything exactly the same as I did a few weeks ago (I wrote myself instructions). Any ideas on what could be happening? thanks so much!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author


    Hi mmcginnis,

    The plugin returns that error message if 1) it cannot find the URL that you entered or 2) if the search/replace urls are identical. (So if you ran the same terms twice, the second time it would give an error message.)

    Please verify that neither is the case.

    It returned results-found the first time I ran the search/replace, and I’m certain the search/replace URLs were different, but it still returned the error message.

    I tried this on a local multisite installation just now and got the same behavior. I have experienced it when the plugin is network-activated and also when I go into an individual blog and activate it (without it activated on any other network site).

    Thanks for your help!

    Plugin Author


    Yes, the first time it is run it will return results. The second time the same EXACT terms from the first time are run, you will get an error. This is because those terms are no longer found, since they have been replaced.

    UPDATE: I’m still getting the error message, but it looks like the search/replace runs successfully. Maybe the error message is just triggered too aggressively?

    This is the error I get on the FIRST time I run the search/replace. It’s on a new blog I created on a local multisite just so I could run the search/replace, which is why there are so few results:

    ERROR: Something may have gone wrong.
    Your URLs have not been updated.
    4 Content Items (Posts, Pages, Custom Post Types, Revisions)
    0 Excerpts
    0 Links
    3 Attachments
    0 Custom Fields
    Why do the results show 0 URLs updated?
    This happens if a URL is incorrect OR if it is not found in the content. Check your URLs and try again.
    Plugin Author


    Ah. Thanks for clarifying. I will look into it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Doesn't work after latest release; can't roll back’ is closed to new replies.