• Hey, I’m trying to display a button based on a user’s location, but the plugin doesn’t work.

    When I set the debug parameter it works perfectly. But when I visit the site, the content is not showing as it should.

    Can you advise?

    Currently I’m running the default Elementor button, because I can’t have disfunctioning website element. But I’ll try any possible solution.

    • This topic was modified 1 month, 4 weeks ago by stanikub.
    • This topic was modified 1 month, 4 weeks ago by stanikub.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi.

    You need to wrap your button with the geot shortcode, here an example.

    [geot country=”Argentina”] <button>This is a button to Argentina</button> [/geot]
    [geot country=”Portugal”] <button>This is a button to Portugal</button> [/geot]

    Regards

    Thread Starter stanikub

    (@stanikub)

    Hey, thanks for the answer.

    I did that, but that didn’t work. I’m from Slovakia, so I have a Slovak IP address, but when I set the shortcode as [geot country=”Slovakia”] <button></button> [/geot], the button didn’t appear.

    When I put the debug parameter ?geot_debug=SK, it appeared perfectly. So I guess it somehow doesn’t recognize Slovak (or other) IP addresses.

    Plugin Author Damian

    (@timersys)

    What do you get in de settings page debug data?

    Thread Starter stanikub

    (@stanikub)

    So I have this in the shortcode:

    [geot country="sk"]
    <div class="elementor-widget-container">
      <div class="elementor-button-wrapper">
    <a href="https://www.dedoles.at/lustige-socken" target="_blank" role="button" class="tlacidlo">Kaufe lustige Socken</a>
      </div>
    </div>
    [/geot]
    
    [geot exclude_country="sk"]
    <div class="elementor-widget-container">
      <div class="elementor-button-wrapper">
    <a href="https://www.dedoles.de/lustige-socken" target="_blank" role="button" class" target="_blank" role="button" class="tlacidlo">Kaufe lustige Socken</a>
      </div>
    </div>
    [/geot]

    In Slovakia I should have dedoles.at button and elsewhere dedoles.de button
    I cleared the cache and minified CSS/JS, but I see dedoles.de button

    In settings debug there is:

    Check what Ip's yor server return
    
    $_SERVER[REMOTE_ADDR] = "188.167.64.242
    
    cloudflare
    $_SERVER[HTTP_CF_CONNECTING_IP] = not resolved
    
    Reblaze
    $_SERVER[X-Real-IP] = not resolved
    
    Sucuri
    $_SERVER[HTTP_X_SUCURI_CLIENTIP] = not resolved
    
    Ezoic
    $_SERVER[X-FORWARDED-FOR] = not resolved
    
    Akamai
    $_SERVER[True-Client-IP] = not resolved
    
    Clouways
    $_SERVER[HTTP_X_FORWARDED_FOR] = 188.167.64.242, 188.167.64.242
    Plugin Author Damian

    (@timersys)

    The Ip it’s right and the shortcode also. Are you using any page cache plugin or server cache?

    Thread Starter stanikub

    (@stanikub)

    I am using WP fastest cache, but even if I disable it, it still doesn’t work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.