Support » Plugin: Gutenberg » Doesn’t work

  • Resolved rosweed

    (@rosweed)


    I’m using the Flexible Pro theme. Gutenberg just shows up as a blank box on my dashboard. The demo doesn’t even work. I don’t understand the need for this anyway.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    When that happens, could you try just refreshing the page and seeing if the content shows up then?

    Thread Starter rosweed

    (@rosweed)

    Nope, still just a blank box on my dashboard. In order to post, I have to deactivate it.

    • This reply was modified 5 years, 6 months ago by rosweed. Reason: Additional info
    Moderator Marius L. J.

    (@clorith)

    That’s not ideal at all, I agree.

    There’s two things we can do, we can start off with the easiest task, and seeing if there are any errors showing up. When you open the Gutenberg editor they will show up in the JavaScript console, you can see who to view that by following step 3 in our guide to discovering JavaScript errors. (you can ignore the first two steps, they’re not really needed in this scenario).

    If not, it might be a plugin or theme conflict. The way to test for this is to disable all other plugins and using a default theme (such as Twenty Seventeen). We do understand that’s often not an option on a live site, but you can then use the Health Check plugin, it has a Troubleshooting Mode that will let you enable/disable plugins and themes only for your user, without affecting the site for your normal visitors.

    Thread Starter rosweed

    (@rosweed)

    This is beginning to look a little above my skill level, but I think I found what you’re asking for:
    1. Uncaught ReferenceError: mediaWiki is not defined
    at wikibits.js:243

    2. secure.quantserve.com/quant.js:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT

    Does this help?

    Moderator Marius L. J.

    (@clorith)

    That does help, it looks like you might have one or two plugins that are potentially stopping more code from running.

    One seems to be a related to a wiki of some kind, the other one is your adblocker preventing something from loading a tracker (slightly besides the point, but I’m quite curious what is trying to add a tracker in your admin area, granted that’s not related to Gutenberg right now).

    If possible, could you try deactivating your wiki-related plugin (or using the Health Check option I mentioned previously if you don’t wish it to affect normal site visitors), and see if that makes the editor load as it should?

    I had a similar problem, which was solved by disabling a “pagebuilder” plugin.
    There can also be similar problems due to css sheets of same names, or parameters of same names, being held residually in caching systems on wordpress, in php, on the server, in CDNs along the way, and the users browser.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Doesn’t work’ is closed to new replies.