Support » Plugin: wpForo Forum » Doesn’t work

  • Resolved yugensoft

    (@yugensoft)


    Latest version. On localhost.

    Accessing a page with [wpforo] shortcode just shows a “This site can’t be reached. The connection was reset.” page, after it tries to access for a few seconds.

    Accessing admin pages works.

    All debugging is on. No errors are picked up. Just dies. Other pages work fine.

    • This topic was modified 5 years, 7 months ago by yugensoft.
    • This topic was modified 5 years, 7 months ago by yugensoft.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    Hi @yugensoft,

    1. Please navigate to Dashboard > Settings > Permalinks and make sure your WordPress doesn’t use the default ?p=1 permalink structure. It should be one of the SEO friendly permalinks, such as /%postname%/ or so…

    2. Make sure other pages of your WordPress works.

    3. Check whether mod_rewrite is enabled: https://stackoverflow.com/questions/42592227/how-to-enable-module-rewrite-in-apache-configuration

    4. Navigate to Dashboard > Forums > Settings > General tab, click on the [Update Options] button, then open forum using Visit Forum link.

    Thread Starter yugensoft

    (@yugensoft)

    Thanks for the rapid reply.

    1. It was set to the postname permalink
    2. As mentioned, other pages do work, as long as they don’t have [wpforo] in them. They also work when they include shortcodes from other plugins.
    3. mod_rewrite is enabled since other pages are accessible through their rewritten url
    4. I did that and it didn’t work

    Please let me know where the rendering of the wpforo shortcode occurs, so I can debug it myself.

    Plugin Author gVectors Team

    (@gvectors-team)

    Please make sure your PHP version is 5.6 and higher.

    Also try play with “Enable Output Buffer” option in Forums > Settings > features admin page.

    Also please install the Health Check plugin and leave the report here.
    https://wordpress.org/plugins/health-check/

    Please disable other plugins and change the theme to default.

    • This reply was modified 5 years, 7 months ago by gVectors Team.
    Thread Starter yugensoft

    (@yugensoft)

    PHP 7.1.5
    Enable output buffer had no effect.

    I can’t install that plugin because there are multiple 1 star warnings not to.
    I’m not disabling other plugins and changing the theme (stock wp theme) to try and get this to work. Other plugins have no problem.

    I guess I’ll just debug it myself; a client wants to use it on their site.

    Plugin Author gVectors Team

    (@gvectors-team)

    That’s very important for us to know why on some localhost it doesn’t work. The Health Check plugin have been recommended by moderators. I think this is a PHP configuration issue. Some very important libs are not enabled.
    1. Make sure Multibit string functions are enabled
    2. Make sure XML parsing functions are enabled.
    3. Navigate to Dashboard > Forums > Dashboard and find the copy the Server Information and paste here.

    Please check the Server Requirements
    https://wpforo.com/docs/root/wpforo-installation/server-requirements/

    Thread Starter yugensoft

    (@yugensoft)

    Web Server Apache/2.4.25 (Win64) OpenSSL/1.0.2k PHP/7.1.5
    PHP Version 7.1.5
    MySQL Version 5.7.18
    PHP Max Post Size 8M
    PHP Max Upload Size 2M
    PHP Memory Limit 256M
    PHP DateTime Class Available

    extension=php_mbstring.dll (enabled)
    xml_parser_create() returns OK (XML Parser extension bundled in windows version)

    Plugin Author gVectors Team

    (@gvectors-team)

    Thank you @yugensoft,

    3. Navigate to Dashboard > Forums > Dashboard and find the copy the Server Information and paste here.

    How about this?

    Two more things please.
    1. Please copy the content of this WordPress .htaccess file and leave it here.
    2. Also, please copy the full URL of the forum page and paste it here.

    • This reply was modified 5 years, 7 months ago by gVectors Team.
    Thread Starter yugensoft

    (@yugensoft)

    I did paste that server info from that place.

    http://localhost/name_of_my_project/community/
    Same as the forum base url setting.
    “Forum” page is intact and set at that url, as a page containing only [wpforo]

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /name_of_my_project/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /name_of_my_project/index.php [L]
    </IfModule>

    # END WordPress

    Thread Starter yugensoft

    (@yugensoft)

    I’ve just tested it on a linux machine and it works OK there.
    So it’s probably a bug related to non-universal paths, which manifests on a windows machine.

    Plugin Author gVectors Team

    (@gvectors-team)

    Great! Thank you @yugensoft

    So it’s probably a bug related to non-universal paths, which manifests on a windows machine.

    Windows doesn’t matter. Half of wpForo developers work on Windows environment using WAMP, XAMPP, Open Server, etc…. We’ve never seen any issue during last to years of wpForo development. wpForo works fine on all kind of OS’s and servers.

    • This reply was modified 5 years, 7 months ago by gVectors Team.
    Thread Starter yugensoft

    (@yugensoft)

    OK, then it’s not fixed.
    Whether you’ve had an issue or not in the last two years has no bearing on whether or not there is an issue in this case.
    Windows 10 + Apache -> doesn’t work. Linux (Ubuntu) + Apache -> works. Other plugins -> makes no difference.
    Correlation doesn’t imply causation, but it can give you hints.

    But I don’t have time to pursue this any further. I just wanted it to just work so I can do this one tweak for the client who wants to start using your forum (instead of XenForo, ironically), which should’ve been a 10 minute job, but as usual there’s always a jagged edge. I’ll just have to use a VM or something.

    Best of luck with your project. I will not give a review since you did make some attempt to help.

    Plugin Author gVectors Team

    (@gvectors-team)

    Thank you very much for your time and for all information you provided us. We’ll try to find the point which makes this issue.

    Usually wpForo installation should take one minute. Just activate the plugin and find forum page at example.com/community/, that’s it.
    We’re really sorry that you got this issue with localhost configuration incompatibility and spent more time. I hope you’ll have many opportunities to get more experience with wpForo and you’ll enjoy working with that. Our support is also available at wpForo Community, you can register and open support topic whenever you need.

    For basic questions please check wpForo documentation:

    Nathan

    (@silvawebdesigns)

    I’ve got the exact same issue, tried all of the above and none it working,

    this is the link:

    https://womenstotalfitnessclub.com/community/

    Please help

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Doesn’t work’ is closed to new replies.