Support » Plugin: More Mails for CF7 » Doesn’t send an email

  • jpdeweese

    (@jpdeweese)


    Shows additional email forms in the interface but doesn’t actually send the additional emails when used (still sends the first two).

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Roy

    (@lev0)

    There are many reasons why a particular email does not arrive; that doesn’t mean this plugin is not adding the email to the queue, nor that CF7 isn’t trying to send it. No additional mail (including the built-in Mail 2) will send if the first email send fails, other plugins could conflict with this one if they modify CF7’s behaviour at all, and any normal misconfiguration of a message can prevent it sending. As the description states, the extra mail “does not include the automatic configuration error detection that the default mails have.”

    Have you tried creating a test form and copying the details from the problematic form’s additional mail into the test form’s first Mail, to automatically detect errors? Have you tried visiting https://www.mail-tester.com/ or a similar service, and putting the address they give you in the additional mail’s To field? It will give a good indication of whether it’s being sent at all and, if so, why delivery could fail.

    I’m sorry but I’m not convinced this plugin itself is the cause. I just created a fresh contact form that only used Mail and Mail 3, both emails arrived fine. I’m using the same v1.0.0 of this plugin as you, and v5.1.6 (the current version) of Contact Form 7. What version are you using?

    Plugin Author Roy

    (@lev0)

    In future, consider creating a support thread before giving a plugin a poor review.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @lev0 Don’t Report this review again, there’s nothing for a moderator to do here or needs doing.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Doesn’t send an email’ is closed to new replies.