Support » Plugin: Header Image Slider » Doesn't seem to work with 3.5 and a 2012 child theme

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m using it on 3.5 with a Twenty Eleven child theme without any problems. HOWEVER, a colleague who ALSO uses 3.5 with a Twenty Eleven child them was having the same problems – no options. It turned out that there was an issue with some file permissions.

    Sadly, he is on 1and1 hosting, and they were very unhelpful. The only thing he was able to do was copy the entire website off onto his hard drive, delete wordpress from his host, then re-upload it into the same folder and after that it worked :-/

    I have the same problem. (operating on MU).

    I am not sure if it is a MU problem, or a general one, but the plugin is broken on ALL of my MU installations, while working on simple single installations.

    I have fixed it (partially) by renaming the options.php to another name (say : options_9) and changing line 66 circa :

    <form action="options_9.php" method="post" id="slider-options-form">

    and line 107 in the main plugin file

    jQuery.get( "<?php echo plugin_dir_url( __FILE__ ) .'options_9.php'?>", function(b) {

    this will make the options appear for me , but the plugin still gives an error on another file (/slider.css.php) .
    Apparently , it is not a good idea to include a second file with the name options.php. Strangely enough – it works on SOME installations, but break others .

    Looking at the code , the author has also chosen a very strange way to include wp core (with wp-load and hard-codded files) – and also has chosen to INCLUDE the css and JS instead of ENQUEUE it .

    I will try to resolve it when I will get some time on my hand .
    In the meanwhile – Maybe the plugin author will have a look. this is a great little plugin , and I have used it in the past to full satisfaction.

    yep, after checking I can confirm that for me it was fixed by doing the above mentioned operations ..

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Doesn't seem to work with 3.5 and a 2012 child theme’ is closed to new replies.