Support » Plugin: Facebook Thumb Fixer » Doesn’t seem to work to set images

  • Just installed this today, to try to deal with Facebook’s new link share update (where you can’t upload photos or change title/content).

    Plugin doesn’t seem to work.

    I tried sharing my post, everything works.

    I changed the featured image, and ‘previewed’ it with your tool in the post editor, and it previews the new feature image. But Facebook fetches the old featured image when I try to share the link.

    I went to debugger and tried to debug, but even after debugging the page, it still grabs the old featured image. (I mean the debugger keeps pulling up the old featured image, despite my having changed featured images to a new one, which the plugin finds).

    Any ideas?

    (Btw, there will definitely be strong demand for a plugin that allows users to bypass Facebook’s new ‘link share’ problem, because people like to pick their own featured images for sharing, and edit their titles and snippets.)

Viewing 1 replies (of 1 total)
  • Plugin Author Michael Ott

    (@mikeyott)

    Hi @buttonsonyoursocks,

    20,000+ users beg to differ 😛

    Did you try hitting the ‘Scrape Again’ button on the Facebook debgugger? I’ve found occasionally you need to do it a couple of times.

    Otherwise try this:

    • View the source of the page/post in question
    • Search for og:image and copy the value of the content attribute into a new tab and hit enter (it’ll be the full path to the image)
    • If you see the image you are expecting to see, then the problem could be one of a few things:
    • View the page source and make sure you don’t have a duplicate set up open graph tags being output by another plugin or your theme. If this is the case, then you don’t need my plugin to do something that should already be working.
    • Try clearing your cache
    • Try hitting the ‘Scrape Again’ button on the Facebook debgugger.

    It’d also be helpful to paste the URL here so I can look for anything obvious.

    • This reply was modified 2 months, 1 week ago by  Michael Ott.
    • This reply was modified 2 months, 1 week ago by  Michael Ott.
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.