Support » Plugin: Syndicate Out » Doesn't seem to work in 3.5.1

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author confuzzledduck


    Thanks for the heads up. I’ll take a look šŸ™‚

    I just installed Syndicate Out, and am having a similar problem. I set everything up, and though it saves my settings, nothing shows up on the remote blog.

    Also, thank you for this plugin–it is going to save me 10 kinds of headaches once it’s up and running!

    i have been using this plugin for a few months now, but I am now having issues with the posts. It started lst week when only 1 out of every 3-4 posts were showing on the remote site. Now, none of the posts are showing.
    I have reinstalled the plugin, but still no posts are showing. Please help!!
    main site:
    remote site:

    Plugin Author confuzzledduck


    I think these are two separate issues.

    Re. the first point about saved settings: I’m developing with 3.5.1 and can’t reproduce this problem. I am about to push a new release of the plugin which makes some changes to the settings system, however, so I’d advise you to update to 0.8 once it’s available and then get back to me if there’s still a problem.

    Re. the second point about missing posts: since WP 3.4 the XMLRPC has implemented a much better set of calls for posting (ie. real WP-specific ones), and in version 0.8 I have moved to using these. I would suggest you update the plugin once it’s available and try again. If there’s still a problem I can investigate further.

    I’ve set it up per the instructions and it’s not pushing new posts to the secondary blog site. Both sites are running on 3.5.1 and the installation of the Syndicate Out was downloaded and installed the day before yesterday —

    maybe this helps:

    The custom field “_so_remote_posts” that get’s added has the following content (at least on my installation):

    a:2:{s:15:”options_version”;i:3;s:5:”group”;a:1:{i:1;a:1:{i:0;a:2:{s:9:”faultCode”;i:500;s:11:”faultString”;s:45:”A name is required for this term”;}}}}

    This error is raised by the taxonomy class of the receiving wordpress, I think…

    frustrating; was working so well till I upgraded to 0.8, now nothing works. I now have to manually update 4 independent blog sites. AAAhhhh.

    Why fix things when they ain’t broke?

    Oh well, looking for another solution to update websites with articles I post on my main site.

    Anyone knows of a program that does this other ‘syndicate out’?



    Plugin Author confuzzledduck


    remopini: That’s very useful, thank you. Taxonomies have always been a bit of a pain. It sounds like a blank term is getting transmitted for some reason. I should reasonably easily be able to catch that and weed them out. Now I’m working with the WP native API I’d like to add more intelligent taxonomy checking, but I’m slightly nervous of slowing the posting process down too much with lots of API calls. It’s a bit of a balancing act!

    hotinthenews: In order to implement new functionality I had to transfer from the old MoveableType API to the native WordPress API. There’s no reason the old version of the plugin won’t still work for you if it did previously, you can download it from the plugin repo. I would be interested to know what the admin of the 0.8 version says for “Authentication” and “Remote API” for the blogs which are no longer working say for you.

    hi ConfuzzledDuck;

    Thanks for the response. here’s what is says in the configuration option of the plugin.

    Authentication: OK.
    Remote API: WordPress 3.5.1.

    It says the same for all 3 domain names I added to the configuration.

    I tried uninstalling and reinstalling and reconfiguring but still the plugin does not work. It does not transfer over any posts I write from my main site to the sites configured in Syndicate Out.

    Having Syndicate Out version 0.8 and all sites operate on WP 3.5.1



    Hello ConfuzzledDuck;

    Thanks for giving me version 0.7. I am back in business. Although now it says this in the plugin config screen:

    Authentication: unknown.
    Remote API: unknown.

    But it works!

    Thanks. Hope you can find what’s causing 0.8 to stop functioning.


    I’m having issues as well on 3.5.1. After inputting site/un/pass I get the following in the row

    Authentication: OK.
    Remote API: .

    ideas? I’m not sure if I’m supposed to be checking the box on the left, every time I do it clears the row when I reload the page.


    Same exact issue as @sleepybrett.

    Was not sure if I should open new thread since same exact issue.

    Our request for support at your site was deleted, so trying here.

    Don’t know what is a progress with fixing this plug in. I have a client who insisted to use this but it just didn’t work on WP 3.5.1

    After Googleing a lot and seeing remopini’s post in this thread
    (using :

    wp_die( print_r($remotePostIds) ); in the ‘function syndicate_out_post’

    I’ve got this error:

    Array ( [options_version] => 3 [group] => Array ( [0] => Array ( [0] => Array ( [faultCode] => 401 [faultString] => Sorry, one of the given taxonomies is not supported by the post type. ) ) ) ) 1
    I made a solution for the problem, dummy one though – just replaced line in the function syndicate_out_post:
    if ( false !== ( $remotePostIds = unserialize( get_post_meta( $postMetaId, '_so_remote_posts', true ) ) ) ) {

    with this one:

    if ( 1 !== 1 ) {

    and now it works….
    So, this is not the right solution but I have no time to deal with this further and hope that this will help somehow to ConfuzzledDuck to continue his good work and make all fixes necessary.


    Plugin Author confuzzledduck


    sleepybrett, Terry: that’s an interesting one, I’ll have to see how that is possible. Thanks for letting me know.

    brbaso: that’s very helpful. Thank you. I suspect your meta data didn’t get syndicated with that fix, although if you’re happy with it and it works then stick with it for now šŸ™‚

    Are you using custom post types, or just one of the default types (post, page, etc.)? Again it’s all taxonomy related and as I said before… they are a pain! I intend to look at a more robust handling of all the possible errors, and which ones can be safely ignored, in the next round of development and this is very helpful information.

    Hi ConfuzzledDuck,

    I couldn’t resist to spend time today digging a bit deeper …
    Yes, you are definitely right – it is about taxonomy.

    Eventually I switched back to the original solution(in the mean time I was trying many things – eg. V07 function syndicate_out_post works nicely within the original V08 syndicate-out.php ..) and it works if I don’t Transmit categories and Syndicate only Selected(plug in settings) category which one, exactly the same, must be formed/present in the remote blog …

    I am really sorry that I cannot help more, must go to my regular jobs but I am sure that you’ll fix this issues in a short time – I think that this plug in have a great potential … šŸ™‚
    I’ll stay tuned.


Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Doesn't seem to work in 3.5.1’ is closed to new replies.