Support » Plugin: Domain Sharding » Doesn't seem to work beyond WP 4.1

  • ¡Hola David!

    I was hoping your Domain Sharding plugin might turn out to still be functional with versions higher than WP 4.1 – but alas, it does not seem so.

    I set up sub-domains to working order (with custom DNS records and a wp-config.php entry as recommended), but the only effect the plugin still has is with regard to the 301 redirection.

    It’s O.K., of course, though regrettable, if a plugin developer does not find justification for putting in the work needed to keep a certain plugin up-to-date. There may be any number of reasons for this.

    Just wanted to let you know there is still interest in your Domain Sharding plugin, and if you were to update it, that would be much appreciated.

    Gracias

    https://wordpress.org/plugins/domain-sharding/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author David Garcia

    (@sultanicq)

    Hi,

    Which is the main problem with the plugin in your set up?

    Here we use latest version of wordpress and the plugin works just fine.

    Regards,

    Thread Starter Gahapati

    (@gahapati)

    Thank you for answering me, David!

    It’s good to see you are still supporting this plugin.

    Here we use latest version of wordpress and the plugin works just fine.

    May I suggest to you that you push an updated readme.txt to the repository with the corrected version number?!
    It is very helpful for users to be able to see up to which version developers think their plugins are compatible. It also shows us, whether a plugin is still “alive”.

    Which is the main problem with the plugin in your set up?

    1. Verify Subdomains does not seem to work at all.
      When I click on it, I’m being warned about an insecure connection (I’m running all domains on Let’s Encrypt SSL). When I click OK, the options page reloads, and that’s it. I checked the file domain.check.valid.txt, and it contains the single string “valid”.
    2. Use protocol less urls does not seem to be having any effect. The page source stays unchanged, regardless of setting.
      This might, however, be due to the SSL plugin I’m using (Really Simple SSL), I’m not sure. I have, since my initial post, changed my sub-domain setup from wildcard to “true” sub-domains which each have their own DNS record and associated SSL cert.
    3. Paths to images (are not) were not replaced, until I happened to read another support threat (Issues with php 7).
      After I removed the reference by changing function check_domain_sharding(&$buffer) to just function check_domain_sharding($buffer) — voila, images are being served from all five of my cdn-subdomains now.

    This is the warning I got before I made the change (I’m also running on PHP 7.0.x, by the way):

    PHP Warning: Parameter 1 to domain_sharding::check_domain_sharding() expected to be a reference, value given in /wp-includes/functions.php on line 3464

    I think this shows there is still some room for improvement 😉
    I am glad, though, that Domain Sharding now at least does its main trick.
    Still, it would be reassuring if you could fix the remaining issues.

    Thanks for your time and effort!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Doesn't seem to work beyond WP 4.1’ is closed to new replies.