Support » Plugin: Jetpack by » Doesn't Seem to Play Well with SSL

  • This plugin does not seem to work with SSL. I have WordPress HTTPS Version 3.3.6 installed and as near as I can tell, whenever the part of this plugin controlling comments tries to connect to, it does so insecurely. The return from this then fails (I would guess the HTTPS code views it as an injection from a non-secure location) which causes the comment to not submit.

    I also have a problem with the Plugin showing up on a generic site users Dashboard. All of those different things to click on plus a login bar. I have to believe that would be extremely confusing to a generic user.

    I’ve had to deactivate this plugin in order to keep my site working under SSL.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Richard Archambault



    That plugin is marked as being compatible up to WordPress 3.5.2; it’s possible there’s something that isn’t working quite right with the latest version of WordPress, but I’d like to help you troubleshoot this nonetheless. Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:

    Make sure to include a link to this thread in your message.

    I also have a problem with the Plugin showing up on a generic site users Dashboard. All of those different things to click on plus a login bar.

    We include the possibility for any user to connect to so that they can get notifications on their mobile device, for example. If you’d rather not let non-admins connect to, you can try this plugin:

    The tips here may also be of use to you:

    Understood, I am at WordPress 3.8.1 (I have a habit of just clicking upgrade whenever it pops up).

    The site URL is:

    If you need ISP specifics (for the SSL configuration) please contact me directly.

    Also, please note that currently (on the site) I’ve commented out the comment section (would have been, really, really, really, nice to have been able to just turn the jetpack comments off) so that the site is just using the regular WordPress comment form. I wanted to keep some of the other features of JetPack without disabling SSL. According to a reader, this has led to some behavior of not connecting securely at login until it is forced with https:// and then after login it wants to flip back and then when it is forced again it sticks (just so you know what you may be dealing with).

    As far as users logging into – that is fine, the thing I was surprised at (when I set up a generic test user) was the “To enable all of the Jetpack features you’ll need to link your account here to your account using the button on to the right” Followed by Stats … with all the modules. Why in the world would a generic user to a site see that on their Dashboard? (and if there is a configuration to not allow that – OK, I haven’t done my homework – but if so – why is it on by default?)

    Plugin Contributor Richard Archambault


    Hi there, sorry for the delay in getting back to you.

    On our end, a developer tried to reproduce what you describe, and was unable to. Could you contact us directly via and let us know all the details you think are relevant (such as the ISP specifics you mention, as well as your exact settings for the WordPress HTTPS plugin). Also, it’s worth pointing out that the “WordPress HTTPS” plugin is not a part of WordPress, but rather is a third-party component. It is possible to use WordPress over HTTPS without using this plugin. When you contact us, make sure to include a link to this thread, please. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Doesn't Seem to Play Well with SSL’ is closed to new replies.