Support » Plugin: Yoast SEO » Doesn’t save changes

  • Resolved supervinnie

    (@supervinnie)


    Hi,
    No matter what I do, the plugin just doesn’t save any changes. I’ve set several items to “Not show in search results” (in order to get them out of my sitemaps). But regardless of how many I try, it simply won’t save. Every time the page reloads after saving, everything is put back to “Turn on” instead of my changes.

    Very annoying because my searchindex is messed up due to thousands of unneeded tags in my sitemap!

    P.s. the form on the pages of the plugin where you can sent a message directly to Yoast doesn’t seem to work either. Once I click “sent” it just reloads and all the stuff I enters is still there. No changes whatsoever….

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Sorry to hear that you’re having trouble excluding certain tags from Yoast SEO generated XML sitemap and the contact form that you see on the Yoast SEO dashboard doesn’t work for you as well.

    Can you please share the relevant tags pages link here with us so that we could take a look at them and verify them on our end?

    We look forward to hearing from you.

    Thread Starter supervinnie

    (@supervinnie)

    Hi,

    Not sure what you mean? Tags pages?
    Either I don’t understand you, or you don’t understand me?

    The Yoast plugin creates a sitemap.xml, and in the menu I can choose wether a taxonomy, tag or something else is included in the sitemap. (it also adds a noindex/index to the relevant page).
    Apart from several other SEO setting, I can click on “turn on” or “turn off”.

    After making the changes I need to make I need to click the button “Save changes”. After clicking, the page reloads.

    The problem is, after reloading all my changes are undone.

    For example: I set “Product_Tags” to “turn off”. After saving is is set back to “turn on”. In fact, every single item in this entire menu is set to “turn on”.

    After digging in the database, I found an entry with “noindex_product-tags”, which has a 0 behind it (turn on). In a backup from last year, I found that same database entry which shows a 1 (turn off).
    For example, this was taken from the database entry: wpseo_titles
    It shows now: “noindex-tax-product_tag”;b:0;s:28:
    It used to be: “noindex-tax-product_tag”;b:1;s:28:

    After changing it in the menu of the plugin, it shows:
    “noindex-tax-product_tag”;b:0;s:28:
    The “0” at the end should’ve been changed into a “1”.

    Plugin Support devnihil

    (@devnihil)

    @supervinnie Thanks for your reply and for clarifying the issue that you are experiencing. We understand now that the settings you have configured on the SEO>Search Appearance>Taxonomies page are not being saved.

    Often, we see problems occur in combination with another plugin or theme. The fastest way to rule out any conflict, is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Twenty.

    Please test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin has a troubleshooting mode, which does not affect normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts

    If you do not feel comfortable to do this yourself or if this does not solve your issue, our Yoast SEO Premium plugin comes with one year of (technical) support.

    Thread Starter supervinnie

    (@supervinnie)

    Hi,

    It took a while to test everything. But I changed to several standard WordPress themes, and I have enabled and disabled all plugins (apart from woocommerce). But to no avail.
    Everythime I try to save anything, the changes are simply not saved.

    Thread Starter supervinnie

    (@supervinnie)

    Is there a list of know conflicts with themes/plugins?
    Maybe even a list of known issues with server side solutions? Such as redis or varnish or even Cloudflare?

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @supervinnie

    We don’t kee a list of known conflicts with certain plugins or themes, but all bug reports and issues are filed on our GitHub repository.

    You’ve mentioned that the Yoast SEO menu options you’ve set for the product tags (such as if it should be shown in the search results or not) don’t save when you click on the ‘save changes’ button, and you’ve tested this with a default WP theme, and only Yoast SEO and WooCommerce as the plugins activated.

    Could you open your browser’s console (where this issue occurs) and check for any JavaScript errors in red and share a screenshot of that with us? You can use a website such as snipboard.io or imgur.com to upload a screenshot and share a link here.

    Thread Starter supervinnie

    (@supervinnie)

    Hi,

    (Jeez, how many people work at your office… every day a new guy?)

    The only error I get is:
    ?v=2.0:16 WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed:

    It seems related to the Jetpack notifications: https://github.com/Automattic/jetpack/issues/9170
    But I can’t find any mentioning if it having any effect on other plugins.

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @supervinnie

    We have several people on our team helping out here on the support forums.

    We tried enabling troubleshooting mode and only having a default WP theme (TwentyTwenty) and only Yoast SEO and WooCommerce as the plugins enabled on one of our test sites.

    We then went to the Search Appearance settings and went to the taxonomies tab and set the product tags (product_tag) to ‘not show in the search results’ and we saved the changes, and the changes were retained – https://snipboard.io/XBqF4r.jpg (and the product tag sitemap isn’t included in the sitemap index)

    We’re not exactly sure why the changes aren’t being saved on your end (the error you’ve referenced in your last reply doesn’t seem to be related to the changes not being saved). Are you able to reproduce this on a fresh installation on a staging site?

    It might be something local to your setup if it still occurs with just a default theme and only those 2 plugins enabled. We suggest you open a bug report by following the steps here – https://yoast.com/help/how-to-write-a-good-bug-report/

    Thread Starter supervinnie

    (@supervinnie)

    Had a few tries this weekend. I can only test on a different server, connected with a different domainname. The server where the problem occurs is a dedicated (and live) website that I don’t want to mess with.

    I installed WordPress, Woocommerce and Yoast but the problem did not occur. I installed a couple more plugins (didn’t bother going through all the settings) and the problem did not occur.
    So, not really sure what is causing it. But the live website still won’t save.

    The only solution I managed to come up with is to look in the database for specific fields and change “noindex-tax-product_tag”;b:0;s:28” into “noindex-tax-product_tag”;b:1;s:28” (change 0 to 1).
    (including many other entries)

    • This reply was modified 8 months, 1 week ago by supervinnie.
    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    We understand that on another test site, the issue didn’t occur. We’re not exactly sure why the error occurs on your live site as we’re unable to reliably reproduce this issue on our end.

    We recommend filing a bug report (with all of the relevant information) as per this article – https://yoast.com/help/how-to-write-a-good-bug-report/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Doesn’t save changes’ is closed to new replies.