Support » Plugin: Event Organiser Posterboard » Doesn’t load – “Uncaught TypeError”

  • Hi Stephen,
    The posterboard doesn’t load on our page (http://thenurserytheatre.com/shows/past/), the shortcode is entered correctly but nothing happens. An error is reported from event-board.min.js:
    Uncaught TypeError: Cannot read property ‘reversed’ of undefined(…)

    We recently migrated from IIS to an Apache server, but I’m not sure if it stopped working after this or already before – everything else on our site seems fine. For comparison, the Calendar and Widget Calendar both work without any problems.

    Do you have any idea how this could be resolved?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Stephen Harris

    (@stephenharris)

    This is odd – do you have any caching on the server?

    Each posterboard gets an auto-generated ID to help identify it (to support multiple boards on one page) – this is used in two places: on the containing div and in a javascript variable which stores the board’s settings. In your case, the IDs are different in those two different places.

    I cannot see how this should be possible.

    One thing I have noticed though is that the IDs remain the same. Without caching, I’d expect a new ID to be generated on each page load. (That said even with caching I’d expect the two IDs to be the same).

    You can see the ID being instantiated here and it’s only used twice.

    My ‘best guess’ is that your caching policy is caching different parts of the page differently (so the javascript variable is cached with one ID, and the HTML body of the page cached with another).

    Hi Stephen and thank you for the fast response,

    I tried disabling all (caching) plugins, but it doesn’t seem to help.
    But I noticed after turning off caching that new IDs are generated each time for both the div and the JS variable – and they’re identical in the first 8 digits but different in the last 5. I suppose this means there’s a few microseconds of time difference between the generation of these IDs.
    Would this confirm that there is a caching problem somewhere, as you suspect?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Doesn’t load – “Uncaught TypeError”’ is closed to new replies.