WordPress.org

Forums

Transposh WordPress Translation
Doesn't let me edit the home page (10 posts)

  1. socialmo
    Member
    Posted 2 years ago #

    The homepage does not allow me to manually edit the automatic translation like I can on all interior pages. I have the translation drop down at the bottom of the page (in the footer) with a box I click to edit translation. When I click the box the green icons don't show up on the page and therefore I can not edit. The client's site is http://www.partnershipsagainstpoverty.org. Can you help me figure this out, please? Thanks!

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. socialmo
    Member
    Posted 2 years ago #

    Anyone?

  3. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Please enable anonymous editing so I will be able to see something, also - you have a few objects missing from your page (returning 404s) I suggest you fix that too

  4. socialmo
    Member
    Posted 2 years ago #

    Thank you, it is set to anonymous. I don't see any 404's. Is there a tool where you see this that I can use?

  5. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Seems like your front page is not getting the edit param from the url, I don't know why this would happen, but I guess something is messing with the way wordpress processes the paramaters sent.

    I don't know how you can bypass it, except setting the edit mode manually in code on your from page when this param (edit=y) is a part of the url

  6. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Ps.

    And the 404's, just look at the net tab of firebug or the chrome dev tools

  7. socialmo
    Member
    Posted 2 years ago #

    Thank you for the insights! Where would I put the edit=y in the url? Does it matter? Does it need parenthesis around it? I am not a developer but learning.

    Have a great day!

  8. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Not in the url (doesn't work, for some unknown reason)

    You need to check for it and change the edit mode in the component, if you are not a programmer, I guess it will be a bit harder to do, but I really hope you'll manage.

  9. socialmo
    Member
    Posted 2 years ago #

    Can you provide the file name I should look in or the code I should edit. I think I can play with it to see if I can get it to work? The client has used the Transposh plugin on the entire site and it has done a good job at allowing manual translation when needed. We have spent a tremendous amount of time doing this and the last part of the project is to do the same on the homepage. Any help would be very much appreciated. This really is a great plugin.

  10. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Yes, please look at transposh.php, it contains the transposh object which has an edit_mode variable, this is the one you should change.

    You can probably look at places in the code that change this value now, and you'll see how this is done. I think you can probably add a line next to the existing one with the exception you need for the homepage.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Transposh WordPress Translation
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.