WordPress.org

Forums

Multisite Language Switcher
[resolved] Doesn't detect the different sites? (14 posts)

  1. atreiju
    Member
    Posted 2 years ago #

    I have multisite install with 2 sites. One in german, one in english (Settings -> General -> Site Language).

    I configured this plugin in both 2 sites.

    Still the plugin doesn't work, all I got is the message "You should define at least another blog in a different language in order to have some benefit from this plugin!"

    What can I do?

    Using WP 3.5-de_DE (maybe this is the problem?!)

    http://wordpress.org/extend/plugins/multisite-language-switcher/

  2. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    No, it runs with WordPress 3.5. Do you use 2 different users?

  3. atreiju
    Member
    Posted 2 years ago #

    No, one single user. It seems, the problem was, that the blogs had the same title! I changed the title, and everything is working now... strange.
    Thanks anyway!

  4. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, strange indeed because my blogs have the same title.

    Cheers,
    Dennis,

  5. julienbechade
    Member
    Posted 2 years ago #

    I do have the same problem…

    2 sites. Swedish for the main one and english in a subsite. Swedish is by default in the network. WP 3.5.1, MLSL 0.9.8.1.

    It works as expected in the subsite but can't detect another language in the main site.

    Strange indeed…

  6. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    Do you configured the plugin in all of your blogs?

  7. julienbechade
    Member
    Posted 2 years ago #

    Thanks for answering.

    Yes.

  8. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    And you still get the message ""You should define at least another blog in a different language in order to have some benefit from this plugin!""?

  9. julienbechade
    Member
    Posted 2 years ago #

    Yes, that's right.

  10. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    And there is more then one admin for the primary site I suppose?

  11. julienbechade
    Member
    Posted 2 years ago #

    That is true.

    I'm super admin and there's two more simple admins for the primary site.

  12. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    OK. You'll find a workaround here.

  13. julienbechade
    Member
    Posted 2 years ago #

    Worked like a breeze!
    Thanks for your help!

    What does this function do exactly?

    [Edit] My question should I've been: Why is the plugin unable to detect all blogs when there's more than one admin?

  14. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    Very good.

    The function overrides the way the plugin collects the blogs in a network.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multisite Language Switcher
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.