Support » Plugin: WP-Optimize - Cache, Clean, Compress. » Doesn’t clean the cache on new post publish

  • Resolved Dan Miller Coding

    (@danmillercoding)


    Happened on a website of mine, whenever a new blog post would be posted, the blog page would not clear the cache automatically.
    It would only show up after 24 hours.
    Had to disable the cache to avoid this issue.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Marc Lacroix

    (@marcusig)

    Hi there,

    Is the blog page a default WordPress blog page, or is it a page builder page with a blog module?

    Marc

    I have exactly the same issue on a site, for me it is a normal WordPress blog page

    not sure if I should start a separate support post for this, or if it is okay to mention this here….

    • This reply was modified 8 months, 1 week ago by omniafausta.
    Thread Starter Dan Miller Coding

    (@danmillercoding)

    @marcusig it is the home page with a get_posts function.
    I belive it also was not showing up in the RSS feed.
    The RSS feed is using
    while(have_posts()) : the_post();
    I’ll post more info when I investigate this deeper. Currently I just disabled the cache.

    Plugin Support Marc Lacroix

    (@marcusig)

    @danmillercoding Thanks.

    The homepage should be purged every time a post is saved / published.

    I tested again to confirm that there hasn’t been any regression, and it works as expected.

    The default RSS feeds (those responding to the condition is_feed() aren’t cached at all, unless if you use an old version of the plugin@.

    Are the posts added manually, or automatically posted?
    Do you use a page builder?
    Do you use Cloudflare or a similar service on your website?

    Plugin Support Marc Lacroix

    (@marcusig)

    @omniafausta It’s usually best to open your own topic, to avoid spamming the other participants.

    I have exactly the same issue on a site, for me it is a normal WordPress blog page

    If the blog isn’t on the homepage, then it’s currently “normal”.
    It’s a basic feature, and I don’t know how we missed it! So we will add it ASAP.

    omniafausta

    (@omniafausta)

    thanks! and sorry for posting on this post!

    Thread Starter Dan Miller Coding

    (@danmillercoding)

    I’ve marked this issue as UNRESOLVED. If anyone has similar issues please follow this new topic where we can track the progress of these issues: https://wordpress.org/support/topic/important-caching-does-not-refresh-after-adding-new-posts/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Doesn’t clean the cache on new post publish’ is closed to new replies.