WordPress.org

Support

Support » Plugins and Hacks » Doesn't change images/assets & S3 plugin not working

Doesn't change images/assets & S3 plugin not working

  • Here’s my goal: I have a wordpress installation reachable at origin.example.com and I want to host on S3 with a domain http://www.example.com

    First I tried just using the plugin with saving it to a folder. The html are saved, but most assets & images that had the link “origin.example.com” remained and did not change to “www.example.com” (even after specifiing www as the domain prefix).

    Second, I donated and downloaded the s3 plugin. when I tried to rebuild the static site, nothing happened. It freezes on:
    “Working on: done scanning for files”

    Really I can upload to s3 myself. But i must hide origin.example.com completely.

    http://wordpress.org/plugins/really-static/

Viewing 1 replies (of 1 total)
  • Update
    ok, i got the s3 plugin to work. sorry about that, it was just a problem on my server (no curl installed)

    about the images and assets – i see they are not transferred to s3 by the plugin. so i do it myself using sync:

    s3cmd sync --exclude '*.php' wp-content s3://www.example.com/

    it works great for now!

Viewing 1 replies (of 1 total)
  • The topic ‘Doesn't change images/assets & S3 plugin not working’ is closed to new replies.