Support » Plugin: Publish to Twitter » Doesn't appear to work

Viewing 5 replies - 1 through 5 (of 5 total)
  • They say use consumer key … tried genrating one then the FAQ says use API .. tried that … still get a message cannot communicate with twitter … sorry app is a fail

    Moderator mordauk

    (@mordauk)

    Give them a little time. 10Up is an extremely reputable company and all of the developers that work there are top-notch.

    Not everyone is a robot, sadly, and cannot always answer support tickets on free plugins in less than 3 hours.

    I would wait however when the reply from the company is refer to the support section of the plugin (with only my initial comment there) and the fact that the installation process has an incorrect step…

    I can appreciate that it is a free offering and they are a for profit entity but what if Microsoft released (oh let me take that back).

    Any product that is released should be QC’d prior to release especially having a company associated with it…

    Moderator mordauk

    (@mordauk)

    A free plugin is very different from a commercial product, please give them the light of day, not one little, itty bitty, tiny sliver of a window.

    Plugin Author Eric Mann

    (@ericmann)

    Twitter has changed their terminology since I wrote those instructions. What used to be called a “Consumer Key” and “Consumer Secret” are now called “API Key” and “API Secret.”

    To get them, follow these steps (I just verified this):

    1. Go to https://apps.twitter.com/ and either create an app or use an existing app.
    2. Under Application Settings, you’ll see “API Key” – on the far right of this line is a lick to “Manage API keys.” Click this link.
    3. You’ll now see both your API key and API secret – and the permissions of the app. The app needs write permissions, or it will be unable to post to your account.

    On your settings page (Settings >> Publish to Twitter) put your API key in the Consumer key field and your API secret in the Consumer secret field. I’ll update the UI in the plugin to match Twitter’s terminology change with the next version.

    Click Save Settings or the keys won’t be stored in WordPress and you won’t be able to authenticate.

    Now click “Authorize Twitter Account” to authorize your account.

    I have noticed intermittent failures with Twitter’s API, resulting in a “Bad Authentication Data” error from Twitter’s side of things. We’ll add more robust handling of this in the future, but for the time being I’ve stepped through the issues above and verified that things are working.

    If you continue to face issues, please report them here.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Doesn't appear to work’ is closed to new replies.