Support » Plugin: Simple Shortcode for GoogleMaps » Does this plug-in allow to add 2 pins(addresses)?

  • Resolved zzlatevv

    (@zzlatevv)


    Hey there,

    Thanks for the great plug-in. I have a question – does this plug-in allow to add more than one pin(address)? Right now, I can add one pin using this shortcode, but I’m looking to add a second pin.
    [pw_map address=”New York City” key=”API”]
    And one more question, actually how can I add an address because it doesn’t work on my end. It’s working only if I add “New York City”.
    Thanks in advance!

Viewing 15 replies - 16 through 30 (of 37 total)
  • Plugin Author Alan Fuller

    (@alanfuller)

    I have released v 1.5.1 which has more info in the error messages, njow we will be able to see the return status from Google

    Thread Starter zzlatevv

    (@zzlatevv)

    Thanks. Here’s the new error message:
    Something went wrong while retrieving your map, please ensure you have entered the short code correctly. Address: Statue of Liberty National Monument NYC Status: REQUEST_DENIED

    Thread Starter zzlatevv

    (@zzlatevv)

    Are you absolutely certain you are using quote and not speech marks?

    The best thing do do is delete all quotes and then use single quote.

    I deleted all quotes. Here is the result:
    https://www.screenpresso.com/=XZkog
    But still, I get the same page error.

    Plugin Author Alan Fuller

    (@alanfuller)

    Have you upgraded to 1.5.1 as the error has more information, so it wont be the same error message

    Edit

    Didn’t see earier response

    REQUEST_DENIED

    That means Google doesn’t allow you to geoencode ( for that domain)

    You need to change your permissions / restrictions in the Google Maps API for your key

    • This reply was modified 6 months, 3 weeks ago by Alan Fuller. Reason: Didnt see other reponse
    • This reply was modified 6 months, 3 weeks ago by Alan Fuller.
    Plugin Author Alan Fuller

    (@alanfuller)

    Thread Starter zzlatevv

    (@zzlatevv)

    Everything works fine with other Google Maps plug-ins.
    The error I sent you appeared after the last update. There are no errors on the page before the update.

    Plugin Author Alan Fuller

    (@alanfuller)

    There was no error shown before the last update because the errors were not shown – just a blank page if it errored.

    I changed it so the errors are shown so that you can debug.

    The error indicates that you have not allowed the Geoencoding API on your key

    https://ibb.co/vmJd1Ks

    Thread Starter zzlatevv

    (@zzlatevv)

    Thanks for your reply.
    I have a working map on the same website using another plug-in with this API key.
    https://www.screenpresso.com/=AdcAf
    And I have enabled and allowed the Geocoding API on the very same API key.
    https://www.screenpresso.com/=x34Ef

    Plugin Author Alan Fuller

    (@alanfuller)

    Was geo encoding enabled before, or have you just turned it on?

    Thread Starter zzlatevv

    (@zzlatevv)

    It was enabled all the time. As I said, I have a working map on the same website with the very same API key. Thanks once again for your time, I really appreciate it!

    Plugin Author Alan Fuller

    (@alanfuller)

    What happens if you call the geo encoding URL directly

    https://maps.googleapis.com/maps/api/geocode/json?key=YOUR_KEY_HERE&address=New+York

    • This reply was modified 6 months, 3 weeks ago by Alan Fuller.
    Plugin Author Alan Fuller

    (@alanfuller)

    I have also added more information to the error message with Google detail maybe that will help you work out why your API key is not being accepted for geoencoding.

    Version 1.5.2

    Thread Starter zzlatevv

    (@zzlatevv)

    This is the result:
    “error_message” : “Invalid request. Missing the ‘address’, ‘components’, ‘latlng’ or ‘place_id’ parameter.”,
    “results” : [],
    “status” : “INVALID_REQUEST”
    }

    But the very same API key works with another Google Maps plug-in without any errors.

    Plugin Author Alan Fuller

    (@alanfuller)

    Looks like you didn’t actually correct edit the URL.

    In any case what does the new error say on version 1.5.2

    Thread Starter zzlatevv

    (@zzlatevv)

    Something went wrong while retrieving your map, please ensure you have entered the short code correctly. Address: Statue Status: REQUEST_DENIED Google Msg: API keys with referer restrictions cannot be used with this API.

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘Does this plug-in allow to add 2 pins(addresses)?’ is closed to new replies.