Support » Plugin: WooCommerce Shipping & Tax » Does the plugin really require the JetPack Plugin?

  • Looking at other plugins like WooCommerce payments, this plugin should follow suite and do the same thing. EVERY module is turned off and this plugin is unnecessary. However, even with all modules off, it’s still causing issues. So please do that.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Sandip Mondal – a11n

    (@sandipmondal)

    Hi @harikjr88,

    Sorry to hear that you are facing issues even after turning off the Jetpack modules.

    Looking at other plugins like WooCommerce payments, this plugin should follow suite and do the same thing.

    Internally, we’ve been looking into this but we do not have an ETA at the moment. Please keep an eye out for the changelog here.

    EVERY module is turned off and this plugin is unnecessary. However, even with all modules off, it’s still causing issues.

    Can you please let us know what were the issues you were facing even after turning off the Jetpack modules?

    Can you please share some more details about the issue? It is possible that some other plugin might’ve been causing the issues since turning off Jetpack modules will not interfere with the site.

    Looking forward to hearing back from you to investigate further!

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    Thank you for getting back to me.

    The issue I’m running into with just turning on Jetpack (just to calculate taxes), is that some of my images (even though all modules are confirmed to be off) are loading from the io.wp.com CDN – why? I have no idea.

    https://themotionbooks.com/shop/personalized-tmb/

    The first image loads here: https://i0.wp.com/themotionbooks.com/wp-content/uploads/2020/09/Wedding-Video-Books-CUSTOM-MODERN-LARGE-Front-Gold-300×214.jpg?ssl=1

    And it loads in low quality, so that makes it worse. I wish I can override that at least in code somehow as that is popular page and I’d want that image to be clear.

    Plugin Support Sandip Mondal – a11n

    (@sandipmondal)

    Hi @harikjr88,

    Thanks for getting back and sharing the additional details.

    The issue I’m running into with just turning on Jetpack (just to calculate taxes), is that some of my images (even though all modules are confirmed to be off) are loading from the io.wp.com CDN – why? I have no idea.

    If you’ve turned off the Image Accelerator module under Jetpack > Dashboard then it should not load the product image from WordPress.com servers.

    It looks like the images were cached and the URLs were saved into the database that’s why even after the modules are turned off, the image is loading from Jetpack CDN.

    Can you please try to clear cache and transients from WooCommerce > Status > Tools and then re-upload the product images for this particular product and check?

    If that does not load the image from your server then we will purge the image from our end. To do that, please contact us at please contact us at WooCommerce.com > My Account > Support. You may need to create an account before you can access that page.

    Please include a link to this forum thread, so that we can keep track of what’s already been done.

    Looking forward to your reply to assist you further! 🙂

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    Hey Sandip,

    The interesting this is that we never turned on Image Accelerator, but randomly noticed the issue of some images being low quality. So after some investigation, we realized it’s the JETPACK plugin (we deactivated plugins one by one). The only plugin deactivated that would allow the original images from our server to load was JETPACK.

    I searched for https://i0.wp.com/themotionbooks.com/ in the database and was not able to find anything.

    Replacing the image with a new one (named differently) did the trick. It’s just odd that randomly the jetpack image accelerator caches images.

    I’ll also have jetpack purge some of the other images.

    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    The weird thing is, I reloaded the new image (with a new file name), it seemed to have worked. But a week later, I can see that the image is loaded form the i0.wp.com image CDN!!! WHY!!!!

    Plugin Support Chris M. – a11n

    (@csmcneill)

    Hi again @harikjr88,

    As @sandipmondal mentioned, images loading via the i0.wp.com CDN while the Image Accelerator module is deactivated is definitely not expected, and I can understand how frustrating this has been for you—it’s been over two weeks of dealing with this issue.

    On our end, I can confirm that the Image Accelerator module is deactivated on your site. However, when visiting it for the first time (which rules out browser caching), I’m still seeing that images are loading via the i0.wp.com CDN:

    https://d.pr/i/cAknSz
    Full Size

    You previously mentioned the following:

    So after some investigation, we realized it’s the JETPACK plugin (we deactivated plugins one by one).

    You may have already explored this, but I wonder if a caching plugin like WP Rocket might be playing a part here.

    Have you also tried deactivating any caching plugins like WP Rocket that may be active on the site to see if they might impact this issue?

    If you’ve already determined that caching plugins aren’t playing a role here, then please contact us at WooCommerce.com > My Account > Support as this is definitely something that we will want to continue to explore further outside of these public forums.

    As Sandip mentioned, please include a link to this forum thread, so that we can keep track of what’s already been done.

    • This reply was modified 4 months ago by Chris M. - a11n. Reason: Added a "full size" link for the image
    Thread Starter Vitaliy Lyubezhanin

    (@harikjr88)

    Hey, thanks for responding.

    We have testing turning off wp-rocket as well (it was probably one of the first things we turned off to test).

    The weird thing is (I’m reiterating), is that I reuploaded the images with a new file name, and somehow it get to WordPress CDN and loading from the i0.wp.com domain.

    Plugin Support Chris M. – a11n

    (@csmcneill)

    @harikjr88 This is definitely unexpected. Jetpack is required for WooCommerce Shipping & Tax to function properly, but Jetpack shouldn’t be making it more difficult for you to run your site.

    I see that you opened up a ticket with us today—thank you so much for doing that so that we can dig into this a bit further.

    Since you’ve been connecting with us here already for some time, I’ll also go ahead and increase the priority of the ticket you created so that we can help you get this sorted faster 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this review.