WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Does not work…for some reason.

[Resolved] Does not work…for some reason.

Viewing 15 replies - 1 through 15 (of 29 total)
  • Well, I guess I found out what’s not working in 3.5:

    When uploading images from Wp-Admin menu (“add files”), it works as usual.

    However, if I am in a blog post for example and want to use the new media gallery uploader (introduced in 3.5), images are not resized before uploading.

    Is there a way to fix that?

    Thanks in advance! If you have any questions, do not hesitate to ask.

    Plugin Author WPsites

    @wpsites

    What browser are you using? Does it have Flash installed?

    Newest version of Firefox and Chrome with Flash installed – both don’t work.

    Like I said, it’s only the new gallery feature that doesn’t work with your plugin. The regular upload feature works.

    Thanks for looking into this!

    Plugin Author WPsites

    @wpsites

    I’ve just pushed a new version up to the WordPress repository that should hopefully solve your problems. Let me know if that’s not the case.

    Nope, sorry 🙁 Installed the new version but still doesn’t work with the new media uploader 🙁

    It took me a while to find out, it only works with “drag and drop”.

    Plugin Author WPsites

    @wpsites

    Ahh ok.

    Well if your browser is Firefox or Chrome then HTML5 will be used and there should be no problems.

    If you use Safari then there is an issue with their implementation of HTML5 so the Flash runtime is used instead. Same for any non Chrome/Firefox browser, the Flash runtime will be used.

    Problem with the Flash runtime is it doesn’t support drag and drop. So unfortunately you’ll need to choose which is most important, resize or drag and drop.

    Sorry about this! It’s because of this that the resize functionality isn’t used by WordPress core.

    If you take a look at the Plupload site http://www.plupload.com/ you’ll see what runtimes are capable of doing what. See not 3 for safari/opera resize issues.

    Plugin Author WPsites

    @wpsites

    Ahh “it only works with drag and drop”, I thought you said drag and drop doesn’t work.

    I will do some further testing on drag and drop versus clicking the button.

    Cool, thanks!
    I am using WordPress 3.5 (latest version) and version 1.1 of your plugin.
    I use Chrome as a Browser.
    The only way your plugin takes effect is via drag and drop.
    When uploading in any other way the picture is still fully sized.

    Please let me know, if you want me to test something.

    I tested my my WP 3.5 + Linux Opera 12.12, it seems not working. I clicked the image I want to upload, waited several minutes but nothing happened. If I disable this plugin, the default WP uploader works again.

    Plugin Author WPsites

    @wpsites

    Yes, looks like I’m going to have to take another good look at this… Give me back the old uploader…

    Could it be that 3.5.1 fixed the problems with “resize images before upload” too?

    Seems like that for me the new media manager (e.g. when writing a new post and inserting images) resizes the images correctly now.

    Can anyone confirm?

    Plugin Author WPsites

    @wpsites

    I REALLY hope it does because I’m at a loss as to what to do next to get this fixed.

    In some situations it seems to work in the media uploader on the post/page editor, for me anyway, but then more times than not it doesn’t work.

    I’ve even asked others for a little assistance with this one but no one has come back with anything.

    Ok – I will let other users of my website (with other browsers etc.) try if it works and will report back 🙂

    Thanks to you for all the hard work you put into this very helpful plugin 🙂

    It fails after the upgrade wordpress 3.5. Still fails for 3.5.1

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] Does not work…for some reason.’ is closed to new replies.