Support » Plugin: Permalink Manager Lite » Does not work with WP 5.0 and Gutenberg

  • Resolved dragon013

    (@dragon013)


    Hello,

    when updated to WP 5.0 and activated Block Editor, there is no way to edit the permalink with this plugin. It also breaks the builtin editing.

    While hovering over the title you usually get a button “edit” for the permalink. This works when plugin in disabled. If you click the button you can edit the permalink.

    With activate plugin you will get another button. It says “edit” but when clicking on it you do not get any form with options but you open wordpress’ options page for permalinks in general.

    Please have a look at it.

    Thanks!

    dragon013

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Maciej Bis

    (@mbis)

    Hi @dragon013,

    it will not be possible to enable the “Edit permalink” button in the Gutenberg editor, but I am working on a new version of plugin.

    When a new version is released, Permalink Manager editor will be added to new editor as a metabox to the sidebar. 2.1.2 version will be released tomorrow or on Wednesday.

    Best regards,
    Maciej

    Hi,

    wonderful! Looking forward to it.

    Thanks!

    dragon013

    Plugin Author Maciej Bis

    (@mbis)

    Hi @dragon013,

    the new version of plugin is relased. In Gutenberg URI Editor is displayed in the sidebar.

    Best regards,
    Maciej

    Hi,

    I just did the update and after a quick test it seems to work.

    Thanks for the fix!

    dragon013

    quoctrang

    (@quoctrang)

    Hi Maciej,

    I just updated to the latest version of Permalink Manager. It worked well for default post but I couldn’t find Permalink Manager option on Gutenberg URI Editor with Custom Post Type.

    What can I do or I have to wait for a new update?

    Many thanks!
    Nguyen

    Plugin Author Maciej Bis

    (@mbis)

    Hi Nguyen,

    the update is released, please check it and confirm.

    Best regards,
    Maciej

    quoctrang

    (@quoctrang)

    Wow! What the fastest ever answer and fix! It works as charm.
    Thanks a ton, Maciej! You save my day.

    Best regards,
    Nguyen

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.