WordPress.org

Support

Support » Plugins and Hacks » Better Font Awesome » [Resolved] Does not work with WP 3.9's updated editor

[Resolved] Does not work with WP 3.9's updated editor

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Mickey Kay

    @mcguive7

    Yep, thanks for the heads up. WP 3.9 includes an update to TinyMCE which is supposedly backwards compatible with all editor plugins (e.g. Better Font Awesome drop-down), but seems to be breaking in this case.

    I’m working on it as we speak and will do my best to have an update out ASAP.

    Thanks again for your feedback, and keep your eyes peeled for an update 🙂

    Sweet!!

    It is a wonderful plugin- thanks for being on top of the issues with WP 3.9.

    Plugin Author Mickey Kay

    @mcguive7

    Okay, we’re all set. I’ve just added version 0.9.2 of this plugin, which solves the issue of the disappearing drop-down icon menu in TinyMCE. Definitely let me know if you encounter any further issues, and thanks so much for your assistance in identifying this issue.

    All the best,
    Mickey

    And we’re in business!!!! Thank you 1000x

    My font drop-down is completely gone after upgrading to 3.9. So is my font sizing. TinyMCE basically barely shows up. Instead there are blank rows.

    Help please?

    Linda, it sounds like you have other issues.

    First, clear all browser cache and recheck.
    Then try uninstalling the plugin and see what happens to tinymce. If the problem persists then another plugin or script is causing the issue and you will need to disable them one by one to find out which one is incompatible with WP 3.9.

    Plugin Author Mickey Kay

    @mcguive7

    Thanks for the response, Jeffrey.

    And thanks for checking in with your issue, Linda. I fully agree with Jeffrey’s response – please try all of those steps, and if the issue still persists, than definitely let me know and I can look into it.

    With the upgrade to WP 3.9 came a pretty serious upgrade in the TinyMCE visual editor that created a lot of problems for a lot of people:
    https://www.google.com/search?q=wordpress+3.9+visual+editor+&oq=wordpress+3.9+visual+editor+&aqs=chrome..69i57j69i64l3.5989j0j7&sourceid=chrome&es_sm=91&ie=UTF-8

    Generally, this problem stems from plugins that add buttons, drop-downs, and other controls in the visual editor, and do say using a method that was supported in the older version of TinyMCE but break in the new version (4.x). Unfortunately, there’s not much to be done other than disabling the plugin and notifying the author (please do this to make sure they know and have a chance to provide a fix).

    I can tell you that I’ve tested Better Font Awesome with WP 3.9 and it’s working just fine for me (and is for Jeffrey too, I believe). So bottom line, try disabling your plugins one by one to see which one(s) is the culprit.

    Best of luck, and let me know if I can be of any further help.

    I did everything mentioned above. Even with all the plugins disabled I still have no fonts to choose from or sizing. I use Thesis and any help would be appreciated.

    Plugin Author Mickey Kay

    @mcguive7

    Got it, thanks for running those checks for me. Being as this is on the back-end of your site, it may be challenging for me to debug the issue without you sharing your credentials with me. If you are willing to do that, I can take a look (simply to look for errors, I won’t make any changes). Please don’t post your credentials here, but if you want to share them you can submit a contact form here:
    http://www.mightyminnow.com/contact/contact-us/

    Otherwise, would you be able to take a look in your browser and see if there are any JavaScript errors popping up in the console: http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Thanks for your time and help!

    You mean my password?

    Plugin Author Mickey Kay

    @mcguive7

    Right, the username and password you use to access yoursite.com/wp-admin

    On its way momentarily.

    OK, just sent it.

    Plugin Author Mickey Kay

    @mcguive7

    Thanks Linda. I also need to know your site URL 🙂

    lol
    really? lol

    http://dofoodbetter.com

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Does not work with WP 3.9's updated editor’ is closed to new replies.
Skip to toolbar