Support » Plugin: SimpleMap Store Locator » Does not work with wordpress 3.5

Viewing 9 replies - 1 through 9 (of 9 total)
  • Carl Rozema

    (@carlrozemaaxcintnl)

    Same problem here. The search fields are shown, but the map keeps loading.

    Ditto … when can we expect an update to this … we use almost 150 plugins across out 1500+ sites .. only 2 have had issues with WP 3.5 and the other one was updated overnight last night.

    thanks,

    Jim

    The solution : Open the file plugins/simplemap/classes/xml-search.php

    at line 115, add a second parameter to the wpdb->prepare function.

    change :
    wpdb->prepare( ” …QUERY_HERE… ” );

    to :
    wpdb->prepare( ” …QUERY_HERE… “, $id);

    Source : http://make.wordpress.org/core/2012/12/12/php-warning-missing-argument-2-for-wpdb-prepare/

    Excellent. Thanks for quick reply!!

    Jim

    T Klein

    (@tklein87gmailcom)

    awesome, works for me! I knew what the problem was but I couldn’t find the right spot to put it. Thanks a ton joost.

    How did you find the right file?

    Hello again,

    You also need to change the remaining ‘wpdb->prepare’ in other files (xml-search.php, locations.php, import-export.php)

    Click here to download the 3 corrected php files and place them in the plugins/simplemap/classes folder.

    edit : @t Klein, I found the right file from the error message i got in Firebug, it pointed to line 115 in xml-search.php

    Good Luck!

    Even better!! I had already started down that path.. thanks for shortening it!

    peace,

    Jim

    Thanks, seems to have fixed it.

    Hi does the .rar file have all the necessary file updates, or is there more to do? I deleted the plug-in, replaced the original files with the three found in the .rar and uploaded it again. Unforutnately I’m still getting the infinite loading icon.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Does not work with wordpress 3.5’ is closed to new replies.