Support » Plugin: Google Website Translator » Does not work to remove the translation banner

  • Resolved edvent

    (@edvent)


    Even tho we have set the setting to Completely hide the translation banner, the banner still appears after translated.

    Is there any possible way to remove it completely?

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Prisna

    (@prisna)

    Greetings,

    most likely the issue is related with the cache plugin you’re using. Make sure to flush its cache and try again.

    Regards

    I now have flushed the cache and it still appears

    This is how it looks after i’ve translated to any language: https://gyazo.com/94fe649ea95160d82e3fb8010c95f227

    Plugin Author Prisna

    (@prisna)

    Thanks but a screenshot isn’t enough, we’ll need to actually see the page, otherwise it won’t be possible to assist you.

    Please enable the plugin and send a link/url where the issue can be seen.

    Regards

    Here’s the the website: https://edvent.se/

    It happens on every page of the website when translated, we are using the shortcode in a popup menu.

    Plugin Author Prisna

    (@prisna)

    Thanks for the link, but that’s not enough. You should provide the means to replicate the issue. The plugin seems to be disabled.

    If it’s being displayed in a non conventional way, then please provide the instructions, as we do not see any popup with the language switcher.

    I hope you understand that we won’t be able to assist you if you’re unable to provide a specific way to replicate the issue.

    Regards

    Hi again. Here’s a short video with what our exact issue is

    Plugin Author Prisna

    (@prisna)

    The plugin is still disabled.

    You can try to add this CSS code:

    body {
    	top: 0 !important;
    }
    .goog-te-banner-frame {
    	display: none !important;
    	visibility: hidden !important;
    }

    As you can see on the video, we are using the plugin, do think it has something to do with having in a popup menu?

    And where is the CSS code suppose to be, in the plugin prisna or in a element?

    These are the plugins we are using and is active :https://gyazo.com/bee933a2d468ca6529d324277eb959b3

    Plugin Author Prisna

    (@prisna)

    Perhaps you enabled the Advanced > Test mode. The language switcher isn’t there. It’s showing only when you’re logged in. Test it in a private/incognito session.

    You’re clicking on a link and the address bar stays the same. Maybe it’s related with that “loading” script/plugin/feature.

    Usually themes have a Custom CSS field, if you can’t find it you should probably contact the theme developer.

    Or you can edit this file:

    https://edvent.se/wp-content/themes/oceanwp/assets/css/style.min.css

    Make sure to delete your browser cache.

    Hi again, we change our minds on how we want it.

    We will use the banner, the only problem now is that when you are using a phone and translates, the banner is in the way of our header when we scroll
    Here’s a picture of how it looks: https://gyazo.com/71441582f5662715209109943a1c1d5c

    Is there any way of solving this problem with some CSS or something?

    Plugin Author Prisna

    (@prisna)

    The way the banner is displayed is defined by Google and cannot be changed.

    You should contact your theme provider and ask them if it’s something they can help with.

    Regards

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Does not work to remove the translation banner’ is closed to new replies.