Support » Plugin: Task Manager » does not work in Multisite

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello,

    It’s php extension intl is not enabled by your server.

    You just need to clear comment(;) before this line in php.ini file:

    ;extension=php_intl.dll

    to

    extension=php_intl.dll.

    If you can’t do that, in the next update we will fix this fatal error.

    Thanks,

    Hello again,

    solution 2, update the func fill_date in task-manager/core/external/eo-framework/core/util/class-date-util.php.

    Replace the function by this:

    function fill_date( $current_time ) {
    			$data = array();
    
    			$locale = get_locale();
    			$date   = new \DateTime( $current_time );
    
    			$data['mysql']   = $current_time;
    			$data['iso8601'] = mysql_to_rfc3339( $current_time );
    
    			if ( class_exists( '\IntlDateFormatter' ) ) {
    				$formatter    = new \IntlDateFormatter( $locale, \IntlDateFormatter::SHORT, \IntlDateFormatter::NONE );
    				$data['date'] = $formatter->format( $date );
    
    				$formatter         = new \IntlDateFormatter( $locale, \IntlDateFormatter::SHORT, \IntlDateFormatter::SHORT );
    				$data['date_time'] = $formatter->format( $date );
    
    				$formatter    = new \IntlDateFormatter( $locale, \IntlDateFormatter::NONE, \IntlDateFormatter::SHORT );
    				$data['time'] = $formatter->format( $date );
    
    				$formatter                   = new \IntlDateFormatter( $locale, \IntlDateFormatter::FULL, \IntlDateFormatter::SHORT );
    				$data['date_human_readable'] = \ucwords( $formatter->format( $date ) );
    			} else {
    				$data['date'] = $date->format( 'n/j/y' );
    				$data['date_time'] = $date->format( 'n/j/y, g:i A' );
    				$data['time'] = $date->format( 'g:i A' );
    				$data['date_human_readable'] = $date->format( 'l, F j, Y \A\t g:i A' );
    			}
    
    			return apply_filters( 'eo_model_fill_date', $data );
    		}

    This fix will be available in Task Manager 1.6.2.

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘does not work in Multisite’ is closed to new replies.