Support » Plugin: Picasa and Google Plus Express » Does not work. Blank screen.

  • Resolved dhaval04


    I installed the latest version 2.0.1 on wordpress and configure the setting. But it does not fetch images form Picasa. I have public and prive images but it does not fetch any of it.

    When I click on Picasa Icon on post page, it will display pop up dialogue “Add Picasa image or gallery” but its complete blank without any images.

    Am I missing something?

Viewing 11 replies - 1 through 11 (of 11 total)
  • I got the same thing until I went to the settings page (Settings -> Picasa Express x2), then scrolled down and requested access to private albums. Once I did, everything showed up. Give it a try.

    Hi Jack,

    I tried that as well and gave access to my blog url from Google. However while doing that I notice that it refers my blog url with HTTP however my blog runs on HTTPS. So when I allowed access with HTTP URL, the settings say invalid response 403. Then I manually changed to HTTPS, the allow part worked and it displayed “Revoke access to private albums”.

    So I am sure it has right to access albums but its not showing anything.


    Plugin Author gjanes


    I have experience with mixing public and private albums, and it works well. Did you have a previous installation of the plugin prior to 2.0.1 – and if so had you granted private album access?

    If so, you might try revoking the access through the plugin and granting it again. There were several fixes applied to the plugin to address issues with Google’s authorization mechanism, and perhaps some of those changes could have affected a previous token, thus causing the authenticated request to Google to fail.

    Give that a shot and let me know if you have any success.

    Plugin Author gjanes


    It could also be related to the request URL using HTTP when your blog is actually running over HTTPS. I’ll see if I can do a bit of testing with authorization via HTTPS and see if the URL generated for Google needs to differ when running over HTTPS.

    I had previous version installed and then I upgraded it.

    While granting access again, the plugin first asked Google with HTTP url.

    This website has not registered with Google to establish a secure connection for authorization requests. We recommend that you continue the process only if you trust the following destination:

    When I click on grant access on Google, it traversed back to settings page with message “Can’t request token: Response code is 403”.

    Now when I tried to change request of access from HTTP to HTTPS,


    It granted access and says “Revoke access to private albums”. So I am guessing it now has access.

    But again it does not load any image nor any album.

    Thanks for looking into it.

    Plugin Author gjanes


    It may be the fact that you manually changed the URL, which would cause what the plugin thinks the URL is to differ from what Google thinks it is. I’ll see if I can make it detect HTTPS and create the URL correctly to begin with.

    I’ll be in touch, hopefully with a bugfix update fairly soon.

    You can always temporarily revert to version 1.5.4 which is prior to these changes that may be the cause of your problems.

    Let will try version 1.5.4 as you suggested.

    Thanks again for looking into it.

    Sorry but version 1.5.4 is also does not work.

    I think something has to do with HTTP and HTTPS while fetching albums.

    Ok. I figured out what is wrong. In picasa-express-2.php at line 100, you wrote,
    $this->plugin_URL = WP_PLUGIN_URL.'/'.dirname(plugin_basename(__FILE__));

    Since my blog is running on HTTPS, WP_PLUGIN_URL does not consider SSL option. So it is referring HTTP connection. Because of that all javascript links are failing since they were pointed via http protocol instead of https. (See )

    So I changed that line to,
    $this->plugin_URL = plugins_url() . '/' . dirname(plugin_basename(__FILE__));

    And now it works.

    I am still using version 1.5.4 since its working. But when you update your code, please take care of above.

    Thanks for all your help.

    After upgrade i have this error after install new version 2.0.1

    Parse error: syntax error, unexpected $end in wp-content/plugins/picasa-express-x2/picasa-express-2.php on line 2448

    Plugin Author gjanes


    The SSL issue should be fixed in version 2.0.2, please give it a try and let me know – I’ll resolve this issue unless you notify me otherwise.

    frenkygo – please start a new support thread and provide me information about your environment. My guess is you may not have the required PHP version.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Does not work. Blank screen.’ is closed to new replies.