Support » Plugin: IBM Watson Assistant » Does not work and no support at all

  • I subscribed to a paid version. Set up a service with IBM and created a container on their website as per instructions. I installed the plugin and entered the requested information. No matter how it always says I need to enter correct credentials (that was easy to find on their website when I manage my container). I have made two support tickets only to find that they are being deleted without any notification. It does not seem to be any other way to get in contact with their support (despite I gave them my credit card).

    The page I need help with: [log in to see the link]

Viewing 13 replies - 16 through 28 (of 28 total)
  • AlwaysEnthusiast

    (@alwaysenthusiast)

    To further clarify the problem. I can add entities with appropriate value when I try to improve watson but that never results in an improved recognition by watson. As mentioned I can add entities but I can’t remove incorrect entities when Watson makes the wrong association. I guess that would be great to be able to do that as well (given that any of these exercises actually change Watson’s behaviour). It would be fantastic if this kind of improving the behaviour of Watson worked.

    Initially I thought Cognitive class was owned by IBM to support their IBM Watson conversation service. However, that does not seem to be the case. It now seems to me that IBM and Cognitive class are not the same. IBM creates the Watson conversation tool and Cognitive class creates this WordPress plugin that links into the IBM Watson conversation service. So far the support from IBM has been almost non existent while the support here from cognitive class is decent. Sorry for incorrectly accusing cognitive class of having poor support (it seems I can’t change the title on this thread)…

    Hi,
    I have the same problem reported by @wolfandgentlemen and @alwaysenthusiast.

    I entered the credentials but it does not work.
    https://gateway.watsonplatform.net/conversation/api/v1/workspaces/{workspaceID}/message/

    I took the {workspaceID} of the [Car Dashboard Sample] from the Watson->Deploy->credentials but no luck.
    I took the complete url from the Watson->Deploy->credentials but no luck.

    and I still cannot figure out the workaround suggested by @alwaysenthusiast.
    I tried to enter https://gateway-fra.watsonplatform.net/conversation/api/v1/ (removing whatever came after /v1/) but the PlugIn returns an error msg “Please ensure you entered a valid workspace URL.” and does not let me save.

    Can you please help ?
    Thanks

    Hi Steph (@steph1369),

    The URL https://gateway-fra.watsonplatform.net/conversation/api/v1/ is the first part of the URL to my workspace. The first part of your URL probably looks slightly different (I guess you don’t have -fra). Look for the URL to your Watson conversation and remove everything after “/v1/”. I suggest try:
    https://gateway.watsonplatform.net/conversation/api/v1/

    Plugin Author cognitiveclass

    (@cognitiveclass)

    Hi @steph1369,

    AlwaysEnthusiast’s workaround was required for the previous version of the plugin as the URL given on your Credentials page was different from the one required by the plugin.

    However, this has been addressed in a recent update and now it should work by simply copying the full “Workspace URL” from your Deploy->Credentials page into the plugin’s setting, without worrying about the “Workspace ID”. The Workspace URL on your Credentials page should look like this:
    https://gateway.watsonplatform.net/conversation/api/v1/workspaces/{workspaceID}/message/

    Is it possible that the username or password you entered is invalid? What is the error you get when you use the exact Workspace URL, Username and Password as they are given on the Deploy->Credentials page?

    Thanks,
    Cognitive Class

    Hi,
    I did simply copy the full “Workspace URL” from your Deploy->Credentials page into the plugin’s setting.
    It looks exactly like you mentioned:
    https://gateway.watsonplatform.net/conversation/api/v1/workspaces/{workspaceID}/message/

    for the username and password: I take them from the Deploy->Credentials page, in the Service Credential section.

    When I use the exact url for the IBM site (Deploy), the plug-in returns “settings saved”, so all seems good….

    …but the chat box does not appear on the web site. but I don’t get any error message anywhere.

    I initially built a chatbot and tried to use the plugin to display it, with no success. So I completely deleted it from the IBM Watson conversation and I now only work with the default Car Dashboard – Sample.

    – where can I look to get some log or error ?
    – is it possible that the IBM watson service is not responding because the limit of 25 entities was reached when I created my own ChatBot …given that the default Car dashboard workspace already has 25 entities (which is the limit on the Lite service).

    any help would be appreciated !

    Thanks

    Also, I tried to put wrong credentials and the plugin then returns error: Unauthorized: Please ensure you entered a valid username/password and URL

    when I put the right settings, then ok. no error msg. settings are saved. So I am sure I enter the proper settings…

    I believe the plug-in installation did not work well with my version of WP (I tried WP 4.7, 4.8, 4.9)…Can I install manually ? I did not find the manual setup instructions.

    thanks

    Plugin Author cognitiveclass

    (@cognitiveclass)

    Hi Steph,

    If you’re getting no error when submitting your credentials, that means your WordPress server isn’t having any issue sending messages to your chatbot.

    What do you have selected for the “Show Chat Box On” setting on the Behaviour tab? Try to select “All Pages Except the Following”, and make sure no checkboxes are selected below it. Then press Submit (the current page selection is slightly confusing, this will be addressed in an upcoming update).

    If there’s a Javascript error preventing the chat box from displaying, it will show up in the console. This can be accessed in Chrome by pressing Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac).

    Thanks for your patience,
    Cognitive Class

    Hi,

    in the Show Chat Box on: All Pages Except the Following = checked.
    and nothing else below.

    By digging into the Console and comparing the html source of the chatbot Ask Ronny Watson from AlwaysEnthusiast, I noticed that my web page (generated by WP) does not include the script call to the ChatBot.

    section starting at:
    <script type=’text/javascript’>
    /* <![CDATA[ */
    var settings = {“delay”:”0″,”minimized”:”1″,”position”:[“bottom”,”left”],”title”:”Ask Ronny Watson”};
    /* ]]> */
    </script>
    <script type=’text/javascript’ src=’http://science-network.tv/wp-content/plugins/conversation-watson/app.js?ver=4.8.3′></script>

    It seems the app.js is not loaded or called, so the chat pop-up does not appear.
    I copied it manually into the html WordPress page, and it’s now working.

    I can not use the plugin to configure it, but is is a start.

    any idea on why the code is not included/generated by the plugin is welcome :-))

    Thanks

    Actually, it is not working yet…I can display another Bot on my webpage but still not mine.

    Plugin Author cognitiveclass

    (@cognitiveclass)

    @steph1369
    Would it be possible for you to create a new topic in the support forum and fill in the “Link to the page you need help with” box? It would help us diagnose your issue.

    Dear Sir,
    I have entered everything as per instructed, but everytime an error pops up and says- “Please ensure you entered a valid workspace URL.” I am using username and password same as in service credential in deploy option of chabot, and in place of workspace url, I have tried all possibles as – https://gateway.watsonplatform.net/conversation/api/v1/workspaces/913214fe-026a-477c-870b-505d70ae71ee/message/
    913214fe-026a-477c-870b-505d70ae71ee
    https://gateway.watsonplatform.net/conversation/api/v1
    https://gateway.watsonplatform.net/conversation/api/v1/
    But none of them worked for me. I have only three option to fill – Username, password and Workspace URL. What should I do?

    • This reply was modified 8 months, 1 week ago by  anurag290.
Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘Does not work and no support at all’ is closed to new replies.