Support » Plugin: Allow Comments on Pages by Default » Does not work

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Sergey Biryukov

    (@sergeybiryukov)

    WordPress Dev

    Hi S S0DEN,

    The plugin respects default article settings on Discussion Settings screen, like WordPress 4.2 did:

    • “Allow people to post comments on new articles”
    • “Allow link notifications from other blogs (pingbacks and trackbacks) on new articles”

    Could you make sure those settings are enabled?

    Yes, the Discussion Settings is ok. I have WP 4.4 version.

    Those have been enbaled the whole time, still the plugin will not display on pages.

    OK folks i think i am on to something here. I got it to work and here is how.

    Go to your pages management in admin and click on edit the page you want. Then at the top of that management page (right by the top bar where your name is and the help button is) there is a screens options button.

    Click on that and select comments.

    You can now put comments under your page while in admin. The comment box should be showing now. This screen option also has a different view after you save the page, go back to your pages listing and click on the screen options again and there are three options. Make sure comments is selected.

    I have not yet figured out how to let members comment on pages but at least this is a step in the right direction.

    If anyone figures this out let me know.

    Thanks
    dave

    And i also noticed as a follow up to my post above that i had to set my default user to contributor in general settings.

    Also i notice that i can comment as a user with all new posts and pages. I think i will have to open the old pages and post (prior to this plugin) and resave them maybe to get it to work for them. But all new ones work.

    Sorry another update here, i was wrong about contributor you have to make them authors in order for them to post, i think lol

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Does not work’ is closed to new replies.