• essaund

    (@essaund)


    It does not work.

    All the webp files generated are larger than the original files. So it deletes them. That happens even when I lower the quality to 75%.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hello @essaund,

    Everything works fine. The plugin consciously uses the original image in this case, it is a planned action. This situation means that you have compressed the images before. You’ve probably used some image compression tool, right?

    You need to know that reducing the weight of .jpg files means a loss of quality. If you convert .jpg. to .webp, you reduce weight without sacrificing quality. For this reason, it is better not to compress the .jpg or .png files themselves, but to convert them to the WebP format.

    I believe that this assessment is not deserved. It is not the plugin’s fault that you previously compressed your images. Am I wrong?

    Best,
    Mateusz

    Thread Starter essaund

    (@essaund)

    Hello,

    I don’t use any image optimization tools in WordPress. But I do resize the images before uploading.

    I did try to select the option not to delete the larger webp files but it would convert and delete them either way.

    Any idea how I can avoid that?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @essaund Thanks for your answer.

    Have you tried to uncheck “Automatic removal of WebP files larger than original” option in the plugin settings and save the settings? And then restart converting all images.

    Thread Starter essaund

    (@essaund)

    Hello,

    As captioned earlier, yes I did that. And it would still delete the webp files.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @essaund Please send me a screenshot of the plugin settings screen.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @essaund After saving the settings, when you restarted image conversion, did you select the “Force convert all images again” option?

    Thread Starter essaund

    (@essaund)

    Hello,

    Yes I did that. =(

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @essaund Sorry, but that’s not possible. One function is responsible for deleting WebP files if they are larger than the original. It is located in this file:
    https://plugins.svn.wordpress.org/webp-converter-for-media/trunk/src/Conversion/SkipLarger.php

    It takes plugin settings and checks if the “Automatic removal of WebP files larger than original” option is selected. The feature does not work if this option is unchecked.

    Can you record a video of me turning this option off, saving the plugin settings and still having this problem? I will be very grateful!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Does not work’ is closed to new replies.