Support » Plugin: Auto Affiliate Links » Does not support Advanced Custom Fields properly

  • Resolved julesworld

    (@julesworld)


    I activate the function “add links on” –> Advanced Custom Fields

    Iam getting following errors:
    Warning: strlen() expects parameter 1 to be string, array given in /www*/aal_engine.php on line 488

    Warning: stripos() expects parameter 1 to be string, array given in /var/www/*/aal_engine.php on line 403

    Can you add a check if variable is array or not?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Lucian Apostol

    (@thedark)

    Hello.

    Apart of those warnings, the plugin works as expected with Advanced Custom Fields ?

    Thread Starter julesworld

    (@julesworld)

    @thedark Yes it does.
    Those warnings appear on top of the site, but the links were set in text.

    • This reply was modified 4 years, 7 months ago by julesworld.
    Plugin Author Lucian Apostol

    (@thedark)

    I’ve added an extra check to prevent showing the warnings. Let me know if the warnings are gone after you update to the latest version.

    Thread Starter julesworld

    (@julesworld)

    That kills the wordpress instance:
    Warning: Cannot modify header information – headers already sent by (output started at /var/www/*/wp-auto-affiliate-links/aal_engine.php:316) in /var/www/*/wp-login.php on line 422

    Plugin Author Lucian Apostol

    (@thedark)

    Please wait for the next update ( 5.6.1.6 ) and let me know if you still face problems.

    Thread Starter julesworld

    (@julesworld)

    Works like a charm. Thank you for your support.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Does not support Advanced Custom Fields properly’ is closed to new replies.