Support » Plugin: Jetpack Post Views » Does not show views for all posts

  • Resolved sijo55

    (@sijo55)


    I started using this plugin yesterday and it will not show views for all posts.
    I’m using this line in single.php :

    echo get_post_meta( $post->ID, 'jetpack-post-views', true ) . ' visninger';

    In my frontpage I’m using this line in misc-function.php :

    get_post_meta( get_the_ID(), 'jetpack-post-views', true );

    I had to use “get_the_ID()” instead of “$post->ID” to make it work here.
    The problem is that it only shows some post views, not all. And that goes for both single and front page.

    Please see attached image that shows part of my front page. (visninger = views in english)
    See image

    http://wordpress.org/extend/plugins/jetpack-post-views/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Steven Lambert

    (@straker503)

    Interesting. Just to make sure, do the posts that are not displaying post views have a post type of “post”? If they are anything else, the plugin does not keep track of their data.

    They are all the same and should show views..

    Plugin Author Steven Lambert

    (@straker503)

    ALright, I think I might have found at least where the issue is occurring. Do they still show as blank and not a number for views? I’m curious to know if it is just that they are at 0 views and I need to just fix that. If they do not have 0 views, please let me know.

    Every article has views, but some are shown as blank..

    Plugin Author Steven Lambert

    (@straker503)

    Let me know if this is fixed in the new version

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Does not show views for all posts’ is closed to new replies.