WordPress.org

Support

Support » Plugins and Hacks » Does not show on posts (in my theme)

Does not show on posts (in my theme)

  • The tabbed plugin would be perfect if it showed up where I need it…

    It does show up on special pages, including the category archives but not on the posts themselves. If I tick the relevant box on the the special pages tab the widget still does not appear on ‘all posts’.

    I’m concluding that if the widget can appear on the category archive pages (after ticking the relevant box on the special pages tab) then the widget is able to register which categories are ticked but then simply does not activate itself on any posts. This may help to clarify where the code needs to be tweaked?

    I will take a look inside the code to see what I can find but I don’t think I’ll get anywhere. Any suggestions – please help!

    https://wordpress.org/plugins/section-widget/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Update and aaagh – I’ve found that my theme has two sidebars; a ‘home sidebar’ and a ‘single sidebar’.

    For the widget to appear on category pages it goes in the home sidebar and for it to aiso appear on single posts it has to also be placed in the single sidebar. I’ll have to see if there’s a way of disabling the single sidebar so one widget does it all…

    Got it to work!

    For anyone reading this, I edited sidebar.php to remove all reference to dynamic_sidebar(2) so that only one sidebar is loaded for all types of posts and pages – Section Widget then determines which individual posts to target.

    Now, what next to sort out…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Does not show on posts (in my theme)’ is closed to new replies.