Support » Plugin: Simple Staff List » Does not display photos

  • Resolved bazzler

    (@bazzler)


    Hi. I am not a very sharp wordpress user, but I managed to much sucess install the plugin and get everything fixed. Except that the photos does not display (everything else does). When I go into the photo gallery I can upload the correct picture, however, when I click “set feature image” it doesnt bring it “back” to the plugin so to speak. I can do everything but not add photos. I dont understand why it does not work. Can anybody help me? Thanks alot. Best regards
    Martin

    http://wordpress.org/extend/plugins/simple-staff-list/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I’m having the same problem. I intend to use this great plugin for a listing of members (120 members) and have already fallen in love with it. I was able to add two more fields to the members and was just about to take it into operation when I discovered that in face I’m unable to attach an image to a staff member.

    Plugin Author Brett Shumaker

    (@brettshumaker)

    Can you both post a link to the website you’re having an issue with?

    Hi hi
    The website is located at http://www.iceatca.com/handbok but the site has a restriced access. I just sent you an e-mail with a password for the site.

    Rgds

    Plugin Author Brett Shumaker

    (@brettshumaker)

    Thanks for setting up a user for me, however I’m unable to see where you’re using my plugin. It looks like you’re using another plugin to display the members on “http://www.iceatca.com/handbok/felagar-fif/” and when I get into the back-end of the site, I can’t see my plugin in the admin menu. I’m assuming it’s because of the permission level on my user. So, unfortunately, I’m unable to help with my account set the way it is.

    Thanks!

    Hi hi
    I am using your plugin on a test page, http://www.iceatca.com/handbok/felagaskra/. The three members were set up a while ago (last fall I think) but when I tried to insert Sif Aradóttir few days ago I was unable to upload her picture.

    The plugin I’m currently using is called Members list. It works but won’t allow me any Icelandic letters and is very fragile (crashes often). I’d much rather prefer your plugin.

    Active plugins can be found here: http://www.iceatca.com/handbok/plugins/

    BeccaFWCS

    (@beccafwcs)

    I am having the same issue. Granted, I am completely new to wordpress. If you could help me figure out why the photos don’t load that would be much appreciated. That, and the only other bug I can’t seem to figure out is why I can make groups, and the groups show there are staff added to them, but I can’t seem to get the groups to display separately apart from one big list of everyone.

    Webstie is:
    http://willamettechristianschool.net/?staff-member-group=administrative-staff

    BeccaFWCS

    (@beccafwcs)

    Reading through several forums I was able to figure out the groups! However I still cannot even add a photo in the editor. HELP! 🙂

    willamettechristianschool.net

    Plugin Author Brett Shumaker

    (@brettshumaker)

    Could you both try using the plugin with the default 2012 theme and see if you still have the problem? I’m thinking that this could be theme related.

    @gudmundurkarl Again, I think this could be theme related especially since, at one point, Simple Staff List functioned correctly. Did you update/edit your theme after installing my plugin and before trying to add this latest member?

    @beccafwcs It also looks like your theme is wrapping some of the output from Simple Staff List in a <code> tag. As far as the groups go, make sure you’re using [simple-staff-list group="Administrative Staff"] where you’d like to display that group. I’m assuming from your link above that you have a staff group named “Administrative Staff.”

    I activated the Twenty Twelve theme and then I was able to upload pictures to the Simple Staff List plugin.

    I am using a theme called Sterling which I purchased from themeforest.com.

    Does the problem lay with a namesystem or what? Is it possible that Sterling and Simple Staff List are using a same function or same name?

    Plugin Author Brett Shumaker

    (@brettshumaker)

    If it was using the same function name it would cause the WordPress WSOD (white screen of death) fatal error, I believe.

    It looks like the problem lies with the theme, then. Are you able to save featured images for regular posts with your theme enabled? If not, I would reach out to the theme developer and let them know their theme has a problem with featured images.

    I am able to save featured image for all post types except for simple staff list. Those include custom post types from other plugins not causing any conflicts.

    Plugin Author Brett Shumaker

    (@brettshumaker)

    I’ll see if I can get a copy of that theme and see if I can figure out where the conflict is happening.

    Absolutely brilliant 🙂

    As you know I aldready had three staff members with pictures working fine.

    1. I open a staff member that aldready has a picture attached.
    2. I remove the picture but do not update the post
    3. Now I am able to attach a new picture to the post.

    But If I updated the post after removing a picture I was unable to attach a new one again.

    BeccaFWCS

    (@beccafwcs)

    Brett, pictures load just fine in the 2012 theme. I have not been able to load staff pictures to the theme I am using however. All other posts and pictures work fine except the simple staff list, thus far. The theme I am using is complexity from themeforest.

    Plugin Author Brett Shumaker

    (@brettshumaker)

    I’m getting a copy of Sterling from the theme developer for testing.

    @becca: Once I figure out what is going on with the Sterling theme, I’m almost positive it will be the same conflict with your theme.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Does not display photos’ is closed to new replies.