WordPress.org

Forums

Child Themify
[resolved] does not copy menus (5 posts)

  1. columbo777
    Member
    Posted 1 year ago #

    I assumed that it would propagate my entire parent theme and site menus, but the menu is gone from the child theme.

    https://wordpress.org/plugins/child-themify/

  2. KWhite
    Member
    Posted 1 year ago #

    Is the menu gone from the dashboard, or just not displaying on the site? The first time you use a child theme you may need to open Appearance >> Menu on your dashboard, and under "Theme Locations" check the box "Primary Menu."

  3. juandrah
    Member
    Posted 1 year ago #

    Also, if you re-installed and used a different database you made need to re-create the menu structure in the new version. as this information is stored in the database.

  4. columbo777
    Member
    Posted 1 year ago #

    I was able to quickly re-add the menu to the theme, which solved the issue. I did not even have to recreate the menu, just add it (as crunchyData surmised)

  5. John P. Bloch
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad you were able to resolve the issue. As much as I'd love to have it automatically set the correct menus, I don't think that is within the scope of this plugin. Since child themify only creates the child theme and doesn't activate it for you, at the point that the theme is created, the menus are correct, since your theme is still active.

    I may end up filing a bug with WordPress itself, though, since that is pretty confusing behavior that would make sense for WordPress to handle.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Child Themify
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.