Support » Plugin: WordPress Crosspost » Does not connect to WordPress.com

  • Resolved barbarajchin

    (@barbarajchin)


    Hi! I’m having trouble getting the plugin to connect to my WordPress.com blog. After I enter the Client ID and OAuth Consumer Secret, I click the button to connect to the WordPress.com blog, and the page opens where I can select to Deny or Approve. But when I click Approve, it goes back to the settings page, and it looks like nothing connected because the “Click here to connect to WordPress.com” button is still there, and nothing is set up. Please help!

    https://wordpress.org/plugins/wp-crosspost/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Meitar

    (@meitar)

    Strange. The OAuth mechanism used in this plugin is line-for-line identical to the mechanism used in Tumblr Crosspostr, and this issue sounds like an issue addressed and resolved by doing the things described here. Maybe try that solution and see if it indeed solves the problem for you?

    Strangely, though, I had a similar issue with the Tumblr Crosspostr (with getting the Deny or Approve screen, and nothing changing after clicking Approve), but now the Tumblr Crosspostr works great after I tried a bunch of different things – and I can’t remember what I did to make it work.

    But I’m still having issues with the WordPress Crosspost … I looked in my php.ini file like that post suggested, but it already reflects a valid path, so I don’t think that is the issue.

    I have tried manually deleting all cookies and restarted my browser. Also tried uninstalling the plugin and reinstalling it. Also tried creating a new API & client secret. None of these did anything.

    I turned on WP debugging mode, and I didn’t get a debug.log in my wp-content folder, but I did see this at the top of the settings page for the WordPress Crosspost plugin:

    Notice: Undefined index: value in /srv/disk12/1216324/www/[domain].com/wp-content/plugins/wp-crosspost/wp-crosspost.php on line 91

    No other thoughts about what could be going on?

    Plugin Author Meitar

    (@meitar)

    Like I said, the underlying code for the two plugins is identical, so no, I have no further thoughts.

    I keep getting this message when I update my post which it supposed to crosspost to wordpress.com

    object(stdClass)#515 (2) {
    [“error”]=>
    string(12) “unknown_post”
    [“message”]=>
    string(12) “Unknown post”
    }

    And I got a message to ask on wordpress.com since the plug in didn’t why we are getting the message.

    Before today all my post were being cross posted with no problem at all.

    Jenn

    Plugin Author Meitar

    (@meitar)

    @barbarajchin, try updating to the latest version of the plugin, released today. I’m not certain this will resolve the issue but I did fix numerous bugs and it might be related.

    Also be sure that your server has the required PHP modules, discussed in the Installation instructions page for this plugin (under the “Installation notes and troubleshooting” headline).

    @jennies627, I’ve never seen an “unknown_post” error from the API before. I suspect WP-Crosspost is trying to update a post that you’ve deleted from the WordPress.com side of things.

    Try deleting the wordpress_post_id and wp_crosspost_destination custom fields from your post and trying to cross-post it again.

    Also be sure to update to the latest version of the plugin before you do this.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Does not connect to WordPress.com’ is closed to new replies.