Support » Plugin: WooCommerce - ActiveCampaign » Does not work – receiving an error

  • Resolved qwik3r

    (@qwik3r)


    I keep getting errors:

    Unable to tag contact from ActiveCampaign: es-woocommerce-activecampaign error: cURL error 28: Operation timed out after 5000 milliseconds with 0 bytes received.

    Then the emails have an array with all the info in it.

    Array
    (
    [email] => customer@name.com (changed for privacy reasons)
    [tags] => Array
    (
    [0] => customer
    [1] => Purchased Product 670
    [2] => The xxxxx Collection
    [3] => Purchased Product 362
    [4] => xxxxx
    )

    )

    My API info is definitely correct

    Please advise.

    • This topic was modified 1 month, 2 weeks ago by qwik3r.
    • This topic was modified 1 month, 2 weeks ago by qwik3r.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author equalserving

    (@equalserving)

    Hi,

    Please check with your hosting company to be sure that they are not blocking the call being made to the ActiveCampaign server.

    Your hosting company will ask for the URL you are trying to connect with – please give them your ActiveCampaign API URL.

    I’m using WPEngine — any other plugin I’ve ever used including those from Active Campaign and every other 3rd party worked. It’s your plugin not the host. I’ve used AM360, the official plugin, etc.

    Plugin Author equalserving

    (@equalserving)

    The default time out for the wp_remote_get and wp_remote_post function is seconds.

    In the next update to the plugin we’ll add an option to extend the timeout.

    So as of right now the plugin is useless until you create something with less of a timeout?

    michalhrehus

    (@michalhrehus)

    I have exactly the same issue. Contacts are not being transfered to Active Campaign when this happens.

    Plugin Author equalserving

    (@equalserving)

    Latest version of the plugin has increased the timeout from 5 sec to 30 sec.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.