Support » Plugin: Blackhole for Bad Bots » Does not add robots.txt rules

  • Resolved titsmaker

    (@titsmaker)


    Hi, I don’t have a physical robots.txt, so it is generated by WP but it lacks Disallow: /*blackhole rule. I thought that it can be related to the fact that SEO Framework modifies robots.txt as well adding sitemap and I was proven right – as soon as I deactivate SEO Framework blackhole rule is in the file.
    I am not sure who should I contact about this conflict. Can you please check this and either fix the issue or prove that the error is on SEO Framework’s side.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jeff Starr

    (@specialk)

    The issue does not happen on default WordPress, only when SEO Framework is active. That means the issue is with SEO Framework. Blackhole plugin makes use of WP core functionality to append a couple of lines to robots.txt. It doesn’t make any other changes to robots.txt. From your description, it sounds like the other plugin is changing robots.txt content, or somehow preventing other plugins from making changes. Best advice would be to ask the authors of SEO Framework for help. They will know best which changes need made to resolve the issue.

    Let me know if I can provide any further infos about Blackhole plugin or how it works, etc. Glad to help anytime.

    Thread Starter titsmaker

    (@titsmaker)

    Thank you for your responce. It seems SEO Framework intentionally rewrites robots.txt, here’s an explanation by plugin author – https://wordpress.org/support/topic/plugin-interferes-with-other-plugins-modifying-robots-txt/#post-14099648

    Plugin Author Jeff Starr

    (@specialk)

    With due respect to @cybr, SEO Framework should be setting an earlier priority, not requiring every other plugin to change the default value to something later.

    But it doesn’t matter really, I will go ahead and set the Blackhole robots function to a later priority, so it runs after SEO Framework does it’s thing.

    Thanks for the legwork on this, @titsmaker.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.