Support » Plugin: Shadowbox JS » Does it work with 3.5?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Ever since updating WP to 3.5 the plugin stopped working for me as well. None of the images use shadowbox and instead just link to the image in a blank page. I’ve tried adjusting the settings etc.,but to no avail.

    I have a similar issue, especially with galleries. This used to depend on whether you linked to the file or the attachment page. With 3.5, neither selection seems to work, and you just get the image on a blank page. Bummer.

    I ended up installing shadowbox manually and don’t use this module.

    Working for me



    I just intstalled it, activated it, and downloaded the source files. Doesn’t seem to work at all. 🙁



    the JS console is giving a few errors:

    GET http://www.[mysite].com/wp-content/uploads/shadowbox-js/src/shadowbox.css?ver=3.0.3 404 (Not Found)
    Uncaught ReferenceError: Shadowbox is not defined

    Why is it linking to a css file in the uploads folder?? I looked in the uploads folder, and indeed there is a shadowbox-js directory, which only contains a handful of encrypted js files, but no other subdirectories such as “src”!

    Could be the reason why it’s stopped working? Although I don’t know if it was having this error in previous versions of WP



    Works for me although WP 3.5 now adds the “alt” attribute instead of “title” to inserted images. This breaks SB’s ability to add titles to the enlarged photo since it looks for the “title” attribute. Manually adding the title attribute works but it’s a very inconvenient fix.

    I posted about this issue but no one has replied yet.

    This sounds like more of a plugin problem rather than a WP 3.5 issue. Either with the SB plugin or a conflict with another plugin.

    First I suggest checking the SB settings page in your WP install to make sure the SB files have been installed. Older versions of the SB plugin included these files by default. But recent versions required you to click a link to install the actual SB files. If you don’t click the link to install SB, then SB may not work even if an older version did because the path to the SB files changed at some point.

    You also might try disabling, deleting and then reinstalling the SB plugin.



    I just got it working by disabling the cache option from the settings page. Although, I’m having trouble loading YouTube videos…

    Thanks a lot vind. It works!

    You just have to go to “wp-admin/options-general.php?page=shadowbox-js” and set “Use Cached shadowbox.js” to “false”.

    I installed it today and I can’t get it to work and I’ve used a lot of suggestions including:

    • I set “Use Cached shadowbox.js” to “false”.
    • making sure the other SB files were installed
    • tonysmithdesigner suggested:
      I’m not sure if this will help but I spent 2 days working on my issue which fell under the category “Shadowbox not working”.

      I manage multiple sites and have been using Shadowbox JS on several of them. I installed the plugin on all of them using the WordPress Admin > Plugin panel. Until recently this was fine but the plugin failed to work on the latest site I’m in the process of building. To be more specific, the plugin partially worked but failed to open images in a light box. The plugin did generate the required (rel=”shadowbox…”) attribute for all links with images but for some reason images would only open in a page and not in a light box.

      My solution was to go to the author site ( and download the source files manually. I selected all the player options, downloaded the source files, then uploaded only the shadowbox.js file to my server. I chose the location wp-content/plugins/shadowbox-js/js/shadowbox.js for my purposes but this shouldn’t matter. Keep in mind, this is in addition to retaining the active version of the plugin already installed in the Admin panel.

      I then updated my header.php file to include a static reference to the shadowbox.js file AND included the Shadowbox.init(); call like below. I tried commenting them out individually and it turned out that both needed to be included for it to work. In addition, this update had to be included below the default <link> and <script> tags that the plugin generates.

    • none of that worked.

      Does anyone have any other suggestions?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Does it work with 3.5?’ is closed to new replies.