Support » Plugin: PayPal for WooCommerce » Does it work with WooCommerce Germanized?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor angelleye

    (@angelleye)

    We have not specifically tested this, but I have not had any reports from users of issues with it. I don’t know if that’s because it works fine or if nobody else is using the combination.

    I would recommend getting everything running on a staging site so you can setup the plugins together and run PayPal sandbox test orders. If there are any issues you’ll be able to find it there before ever going live with anything.

    Yes, there is an issue with Woocommerce Germanized. If you use “Lastschrift” in Germanized Pro Plugin AND “Paypal for Woocommerce”, than you can not enter IBAN BIC etc. because the entry fields are missing. Vendidero support said:

    “das ist korrekt und liegt leider an dem PayPal-Plus-Gateway. Das Plugin ist scheinbar nicht darauf vorbereitet, dass Zahlungsmethoden weitere Felder hinzufügen könnten. Ich denke da hilft es nur auf eine Reaktion der Plugin-Entwickler zu warten.”

    Translated: “The PayPal Plus Gateway plugin is apparently not prepared for the situation that payment methods could add more fields”

    @ Angelleye: Maybe you could reach out to https://vendidero.de/support and try to get this problem solved ??

    Plugin Contributor angelleye

    (@angelleye)

    Thanks for the feedback.

    Yes, we’ll certainly look to get this resolved as I have had this reported from numerous people now.

    What we are probably going to end up doing is splitting Plus out into its own separate plugin. It may be a couple of months before that sort of thing is ready, though, unfortunately.

    I’m sorry I don’t have better immediate news for you.

    Yes, thank you. I think it is not that big issue right now, because if someone is using “Lastschrift” from Germanized Pro, he / she does not need “Lastschrift” from Paypal Plus and the other way round.
    But still, it´s quite nagging to know that there is that specific bug / problem 🙂

    By the way: is “Paypal for Woocommerce” latest version ready for Woo 2.6? Or do we have to wait for a new version??

    Thanks and all the best!

    Plugin Contributor angelleye

    (@angelleye)

    We have been working on the 1.2.0 update for a while now, and it’s very close to ready, but we keep finding “one last thing” we want to add to it, which now includes ensuring 2.6 compatibility.

    I haven’t had any reports of problems, so that’s generally good news. We’re going to be running more tests and getting our 1.2.0 update released very soon.

    So far it seems to work for me. I’m using only PayPal PLUS payment methods plus invoice payment (non-PayPal), i.e. the direct debit issue does not affect me.

    The only other issue I found so far is that it does not work if the WordPress/WooCommerce language is set to “Deutsch (Sie)” (de_DE_formal), only with “normal” German (informal “Du” address, which is surely not common for online shops, but no problem in my case). angelleye said it’s due to PayPal not supporting this language setting.

    Plugin Contributor angelleye

    (@angelleye)

    Yes, from what I’ve seen in the documentation PayPal does not support the de_DE_formal language code.

    We are moving PayPal Plus out to its own plugin, though, and we’ll be looking into that more as we get that ready for release.

    Hello Angelleye,
    I am running a wordpress shop ( http://www.chandrum.de ) with woocommerce germanized.
    Everything works well and I am very satisfied with it.

    I just have a short question.
    Is paypal plus running with woocommerce germanized smoothly togehter? …no Problem?

    Thanks a lot for your answer.
    Alex

    Plugin Contributor angelleye

    (@angelleye)

    Actually, it was, but now with the latest updates we have had reports of a conflict. We are working to get that resolved very soon, though, so the next update of the plugin will have this fixed. If you purchase our Plus plugin I will make sure you get the fix as soon as it’s done so you don’t have to wait on the official release.

    Thanks a lot for your quick response.

    The combination Germanized 1.8.10, WooCommerce 3.0.5, and PayPal Plus 1.0.1 works fine for me. Should I avoid any updates in the near future then?

    Plugin Contributor angelleye

    (@angelleye)

    @laserjones, that’s actually a bit surprising to me you aren’t having any issues with PayPal Plus 1.0.1 and WC 3.0.5. We had to make some adjustments in latest versions for WC 3.0 compatibility. If it’s working, though, I’d wait until you see our 1.1.0 update released that we’re working on now. Should be released within a week or so.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Does it work with WooCommerce Germanized?’ is closed to new replies.