Support » Plugin: Mammoth .docx converter » Docx conversion error

  • Error while attempting to convert file: Cannot read property ‘attributes’ of undefined

    The above error was prompted after I updated woocommerce 4.3.0.

    I’ve tried to submit files that could have been uploaded successfully before, and now all docx files prompt this error.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I got the same error message — Error while attempting to convert file: Cannot read property ‘attributes’ of undefined

    I deactivated my updated version of woocommerce, 4.31, but got the same error message.

    Could it be as simple as this? “Warning: This plugin has not been tested with your current version of WordPress.” I’m on 5.4.2

    I’m having the same issue and don’t have woocommerce. I hope the developer will fix this because I always recommend this plugin to my clients.

    Is there another alternative plugin if this one doesn’t get fixed?

    ——————————-
    Error message on all previously uploaded .doxc files:

    Error while attempting to convert file: Cannot read property ‘attributes’ of undefined

    Plugin Author Michael Williamson

    (@michaelwilliamson)

    I’ve just tried Mammoth on WordPress 5.4.2 with WooCommerce installed, and the plugin worked fine for me.

    Could you try using the plugin with no other plugins and the default theme installed and see if you have the same issue?

    Also, could you provide an example document?

    Thread Starter wuxu

    (@wuxu)

    Dear Michael Williamson,
    Thanks for your support, In wordpress comes with a new article feature. When you install woocommerce, there is an additional new product addition page in the background of the site.
    1, so when you upload the docx file using your plug-in on the article page, it will be published to the blog form article directory, if you use the product to add page and use your plug-in to upload the docx file, it will be published to the article directory in the form of product.
    2, now updated the woocommerce, I use your plug-in upload will not appear errors on the article page.
    3. Errors only occur on the product add page of woocommerce.
    4, so before you update the plug-in, I’m going to fix the problem as follows. First pass docx on the article page, then copy all source code text (the classic editor must be turned on) to the product upload page.

    From the fourth point, I don’t think woocommerce is compatible with your plug-in. Because your plug-in works in the original wordpress text editor.


    —————————————
    I also get this at developer console:,As mentioned above, errors only occur on the new product editing page.

    mammoth-editor.js?v=1.15.0:194 TypeError: Cannot read property ‘attributes’ of undefined
    at Module.Ue (blocks.min.js:3)
    at insertTextIntoEditor (mammoth-editor.js?v=1.15.0:177)
    at mammoth-editor.js?v=1.15.0:92
    at tryCatcher (mammoth-editor.js?v=1.15.0:5641)
    at Promise._settlePromiseFromHandler (mammoth-editor.js?v=1.15.0:3660)
    at Promise._settlePromise (mammoth-editor.js?v=1.15.0:3717)
    at Promise._settlePromise0 (mammoth-editor.js?v=1.15.0:3762)
    at Promise._settlePromises (mammoth-editor.js?v=1.15.0:3841)
    at Async._drainQueue (mammoth-editor.js?v=1.15.0:616)
    at Async._drainQueues (mammoth-editor.js?v=1.15.0:626)
    at Async.drainQueues (mammoth-editor.js?v=1.15.0:500)

    Hi, Michael.

    When I load the docx file in the converter, the post shows up correctly in the Mammoth viewer, links and all. I can cut and paste it into the post editor. I’m using the most recent version of the classic editor plugin. The raw HTML looks OK, too.

    However, when I view the messages, I get this: “Warning: Unrecognised run style: ‘Internet Link’ (Style ID: InternetLink)

    Then, when I hit the insert button, I get the same error everyone else does.

    Hope this helps. Let me know if I can send you anything else.

    Hello.
    On my site I don’t use Wocommerce, but I do use the Yoast SEO plugin, after I updated to Yoast SEO version 14.7 I had the error in Mammoth .docx converter. When I tried to upload a .docx file the error was: “Error while attempting to convert file: Cannot read property ‘attributes’ of undefined”. But if I deactivate the Yoast SEO plugin, then Mammoth .docx converter works without any problem.
    Regards

    I have tried getting the plugin to work by deactivating Yoast and another Yoast plugin, Duplicate post. I had to deactivate both of them to get Mammoth to work. If I only deactivated one or the other, it wouldn’t work. Also, even when I deactivated both, I got an error message before successfully converting: “Warning: Unrecognised run style: ‘Internet Link’ (Style ID: InternetLink)

    I can send you some screen shots; what’s the best way to do it?

    One of my clients is getting this error. There is no WooCommerce installed, but we traced the conflict to Yoast. Rolling back to Yoast 14.6.1 restored functionality.

    Plugin Author Michael Williamson

    (@michaelwilliamson)

    Thanks for the reports with Yoast. Do you have other plugins installed, such as the Classic Editor, or is Yoast the only other plugin?

    Yes, Classic Editor is installed, along with lots of others, about 20 for various duties — anti-spam, media sorting, etc.

    Plugin Author Michael Williamson

    (@michaelwilliamson)

    I’ve just published a new version (1.16.0) that updates how the Gutenberg editor is detected. Could you give it a try and see if you still have the same issue?

    The good news is that it converted. The bad news is that I can’t switch to the text tab and I can’t insert links from the editor after the conversion.

    I didn’t get any error messages, either before or after the conversion.

    Now, I didn’t realize this, but I was updated to WordPress 5.5 just before I tested Mammoth.

    Let me know if you need anything else.

    Plugin Author Michael Williamson

    (@michaelwilliamson)

    I’m afraid I don’t have the same issue when I’ve tried WordPress 5.5. Do you get any errors in the Developer Tools console? Do you get the same issue if you disable all other plugins?

    I don’t think my problem is mammoth. I think it’s classic editor. I tried writing a post in the editor, and the same thing happened — no visual access and no link access.

    So it looks like you fixed mammoth. Thank you.

    Thank you @michaelwilliamson
    With the new update of Mammoth .docx converter the problem was solved.
    I have:
    Wordpress version 5.5
    Yoast SEO version 14.7
    Classic Editor Version 1.6
    Mammoth .docx converter Version 1.16.0

    Everything works perfectly. Thanks again and greetings.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Docx conversion error’ is closed to new replies.