Support » Plugin: WP Document Revisions » Documents entry not showing in admin menu

  • Even on a WP installation with only this plugin installed, the menu does not show the Documents post type entry in the admin menu to the left.

    Twenty15 theme. What’s going on? On a separate site with many plugins, the Menu is shown and I can access the Documents area.

    If I force the url
    /wp-admin/edit.php?post_type=document
    the system tells me

    Cheating, are we?

    What is it?

    thanks

    https://wordpress.org/plugins/wp-document-revisions/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m having the same exact issue, and I see that this plugin hasn’t been updated since 8/2014. Is it no longer supported/updated?

    The same issue is posted here, but I doubt it has been resolved:
    https://wordpress.org/support/topic/unable-to-findview-documents-menu-item-in-wordpress-admin-ui?replies=13

    I am looking for an answer as well.

    I have WordPress v4.3.1, and I did a little debugging:

    \wp-admin\edit.php
    Line 33
    if ( ! current_user_can( $post_type_object->cap->edit_posts ) )

    \wp-includes\capabilities.php
    Line 810
    get_role_caps()

    I found that deactivating the plugin and activating it, added some “deny” capabilities to a lot of roles. 12 deny capabilities to be exact. These deny don’t appear in the administrator though, but since I have more than one role, this affects me since the “deny” takes precedence. In order to fix it, you can go to your roles and uncheck deny on these capabilities:

    'edit_documents',
    		'edit_others_documents',
    		'edit_private_documents',
    		'edit_published_documents',
    		'read_documents',
    		'read_document_revisions',
    		'read_private_documents',
    		'delete_documents',
    		'delete_others_documents',
    		'delete_private_documents',
    		'delete_published_documents',
    		'publish_documents',
    		'override_document_lock'

    I wrote some code as well if anybody needs it:

    $manager = wp_roles();
    	$all_roles = $manager->roles;
    
    	// Capabilities to be removed from roles
    	// Copied from \wp-includes\capabilities.php - Line 1472: add_caps()
    	$documents_caps = array(
    		'edit_documents',
    		'edit_others_documents',
    		'edit_private_documents',
    		'edit_published_documents',
    		'read_documents',
    		'read_document_revisions', 		'read_private_documents',
    		'delete_documents',
    		'delete_others_documents',
    		'delete_private_documents',
    		'delete_published_documents',
    		'publish_documents',
    		'override_document_lock'
    	);
    
    	// Remove the $documents_caps from all roles if it's in the array of capabilites and set to false (which means deny)
    	foreach ( $all_roles as $name=>$role) {
    		foreach ( $documents_caps as $doc_cap ) {
    			if ( $role['capabilities'][$doc_cap] == false ) {
    				$manager->remove_cap( $name, $doc_cap );
    			}
    		}
    	}

    no need to update code, just fix capabilites of admin account using a capabilities editor plugin, it’s juste missing *document(s).

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Documents entry not showing in admin menu’ is closed to new replies.