Support » Plugin: Knews Multilingual Newsletters » DOCTYPE apears on customized templates

  • Resolved hectorasencio

    (@hectorasencio)


    Hello,

    I’m having an issue with personalized newsletter templates.

    I build my templates (but I’m not using Knew editable tags by now) because it match my requeriments. I followed the Knews advices and the standard ones for safe newsletter coding, so on…

    The problem is, once uploaded and selected on Knews admin menu the editor shows me the template’s first line of code, without the two or three first characters. I tried to erase DOCTYPE line but then it shows the HTML tag line instead. Always the first line…

    It also is shown when the newsletter is submited.

    Regards!

    http://wordpress.org/extend/plugins/knews/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author creverter

    (@creverter)

    Hello Hector

    Submit your template zipped at: contact at knewsplugin dot com and we test it…

    Regards,
    Carles.

    Sending…

    Hello,

    I’m having the same issue.
    I’m not yet using the editable tags too, I’ve realized about this problem with the ‘<!DOCTYPE>’ while testing my template.

    Could you please share the solution here?

    Plugin Author creverter

    (@creverter)

    @hectorasencio was edited the template with a text editor and was codified the HTML special chars as entities (escaped commas, <> etc.) This can be your case?

    Regards,
    Carles.

    Thanks for your quick answer,

    I’ll check my template looking for special chars, if there is any I will replace it with ascii code and I tell you how it works.

    Great plugin by the way! it’s quite powerful!
    Thank’s a lot, I wont forget writing a review.

    I’ve checked my template.
    That’s not my case. I’m using dreamweaver, but not as a WYSIWYG, I’m writing the code so I can control that everything matches the plugin requirements.

    I have not used any entity instead of the HTML specials chars (to open and close tags, for example, i don’t use &lt ; and &gt ; but ‘<‘ and ‘>’.

    I also tried to paste the hole code to a plain text document (I’m on Mac so I use textedit) and save it as html with UTF-8 encoding, but it is also displaying the first code line in my newsletters.

    I thing it should be something else.

    Resolved!

    I have rerwritten the code of my templates head from scratch, I wasn’t able to found were was the extra space, or wrong special char, but now it works find, so it was my mistake, the plugin is working great!

    I’m having some troubles with image resizing, but i’ll try the solutions i found in the forums, and if it persist, I’ll open a new post!

    Thanks creverter for such a good plugin!

    Resolved too!

    I know this post is closed, but I have to explain how I solved my issue:

    @carles: You was right, my code was full of HTML entities because I used this to compress it: http://inlinestyler.torchboxapps.com/styler/convert/

    But this was not the problem.

    After some falling testings following your suggestions finally I opened the template in the HTML Knews editor (why I didn’t before? I don’t know…) and I discovered the problem: in the moment of create the newsletter from my customized template, the editor ripped out the first ‘<‘ right before DOCTYPE declaration.

    Simply I edited manually and ‘bualá’, newsletter is OK now.

    Lost of thanks for your support, and I hope it will be usefull for someone else.

    Plugin Author creverter

    (@creverter)

    Thank you Hector! Sometimes the windows notepad helps a lot 🙂

    Kind Regards,
    Carles Reverter.

    I don’t think so xD

    What I mean (I want to remark it) is that the issue appears in the step of choose the template that’s allready installed inside Knews… my code was OK, in fact I followed your suggestion of copiyng the lines at the beggining of (in this case) Casablanca template.

    Regards.

    Then… the file was corrupt in the FTP time?

    Nope, I checked it by login the server, and the transfer was OK… in fact I use TimeViewer for file transfer and updated Knews whole plugin in the same way and the other tamplates were fine.

    May be the thing is document’s charset or something like that… I will test it when I found a moment.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘DOCTYPE apears on customized templates’ is closed to new replies.